Noob server build idea 4 - going on number 7

So I was initally going down the NK5 path but I think for more items I’m going down the snafu2 path.

My plan it to replace a current off the shelf NAS, while also doing some light transcoding and still having overheard to deal with a few other side projects latter like video cameras. and finally keeping a VM in place just for a linux distro desktop to have when I want to kick one on.

Case - Existing Lian Li PC 60 case. Going to remove all the fans and replace them all - add in potentially 2 more.
MB: supermicro X9SRA
Proc - E5-2680V2
Ram 64 GB of EEC DDR 3 - brand unknown at the moment
LSI HBA - probably 9201-8 variant.
cables for drives.
cache drive - 2, 1TB 7200 RPM hitachi drives in stripping mode. I might use 4, I have 7 of them figured I’d use them.

OS drive - Crucial 256Gb SSD

4 - hitichi 4TB, 7200 RPM enterprise drives - not NAS drives. Ultrastor line.

EVGA 650W 80+ gold PSU

OS - looking to start by trying out FREENAS Scale. I know it’s in beta but it sounds solid and the base of the software is solid so I think it will work out. If that falls apart I’ll probably try Proxmox or Ubuntu Server next.

Finally last ditch if it all fails I’ll use UNRAID.

Any gaping issues. It seems I can get the MOBO fairly easily and I need an ATX board so this fits the bill. While I know I give up some doing dual processor I don’t think I give up much. If I need more than this I’ll build a transcoding rig separately if that eats up too much.

Since I never seem to pull the trigger. Found a deal for a HP Z420 workstation setup. E5-1650 v2, 16gb of ram, 256gb ssd, - all for 250 ish free shipping.

adding in a lsi card and my expected 4 HD’s and my other SSD (thinking cache drive and OS drives).

Any of you all use one of these.

OK so I got it in hand.
HPZ420 workstation box - E5 2690 CPU, 16gb ram, 256SSD in hand for 248 ish. put a vid card on - booted and I went ahead and put ubuntu 21.04 on just to do so.

works correctly so far. it is a stripped down bios but it works well and has the basics.

Next plan

32gb of more ram if it works out. 4-8gb sticks to keep pairs in play. DDR3 - 2100 seems to be the speed but will double check.

HBA - looking at a new in box LSI 9265-8i branded for Dell. Found a seller with one for 55 dollars not sure on shipping.

Drives - still planning on 4 - 3tb hitachi ultrastors. price is right for a first array.

I don’t see using a ZFS array with less than 4 drives but one never knows

Still planning on TrueNAS Scale for the OS - yes in beta but I want to try it out. I figure with what I read here if all else fails I can fall back on unraid. Also considered using something like Ubuntu Server

anyway 1/2 way there.

ordered a LSI 9265-8i card because it was reasonable price and shipped out of US. for under 50. or at 50.

should be hear soon and I’m assuming here I will have to flash it to IT mode but the firmware I need is a bit of a question. it’s a 2308 based LSI card but I read that I can use the 2208 firmware. HD I haven’t ordered yet but I guess I need to do that.

I put linux on the machine just to validate all the parts right now are working before I start adding and moving things. SO far so good

The 9260 series is based on the SAS2108 chipset, which cannot be flashed to IT mode (or hasn’t yet successfully been flashed to IT mode).

so according to this website and a few other mentions it is possible.

https://forums.servethehome.com/index.php?threads/flash-lsi-9265-8i-to-it-mode.22787/

https://forums.servethehome.com/index.php?threads/lsi-raid-controller-and-hba-complete-listing-plus-oem-models.599/

This says it’s a 2208 based card vs the 9260 model. I’ll be the first to admit information on it is spotty but there seems to be some thread of logic that says remove the cache if it has it (shouldn’t) and flash it with the utility. But there is some comments about a buzzer going off but it works right.

If it doesn’t work I’ll post up the result, if it does I’ll do the same.

Ah, I overlooked the 5. You should be just fine then.

so I put the card aside for now and did a test run with some crap laptop hard drives I have laying around. so 4 - 500 gb laptop drives - taped in place lol. SATA connections using the onboard intel controller as AHCI only. NON raid.

one ssd for the os install.

and truenas Scale. (not core) . nearly touch free install and bam up and working. data pool of 4 drives as RAID Z1 - so far so good. truenas scale has docker and other features Core doesn’t. There is a app repository and you can add a 3rd party app repository (or others) and someone already made a repository called truecharts. Has LIDARR, RADARR, JellyFin and other stuff as avaible. so far so good.

I’m still having issues with the test system and fixing permissions and what file tree is useable but on the outset it seems solid. Also craptastic hardare right - well file transfer of wired laptop across a 1 gb router system I was pushing files to the new box at 90-120 Mb/s. the read was over 400. that’s with the onboard nic.

I have to say at least that part is working better than expected.

no dice on the HBA - the HP Z420 bios won’t let it run the EFI application to flash it back. so have to use a different machine - having a friend help with that as I don’t have another machine to use.

Build 3 right now is still jank HD setup as this is a test but now I’ve moved on to Proxmox for the OS with VM for truenas core, and aVM for Ubuntu server - with server having docker and portainer to have docker containers. Container for Jellyfin works as of now. with network share for them media stack.

SO far it works - but I will say I think trueNAS Scale will work. I found out there are share permission issues and I just didn’t have the right user permission setup

Can you just get an Adaptec HBA?

As of this morning there are 3 Ebay listing for a 9211-8i from a US vendor so if I have to I’ll get one of them or I might get the adaptec, didn’t think about that one but I think that’s still more expensive.

the card I have should work - but the HP board won’t let EFI shell work. SO hopefully I’ll find out tomorrow if it flashed or not.

The main reason for the test build though - is really learing the OS software and installs, as I’ve never done this before. I had high hopes for TrueNAS scale and it does work pretty well. but knowing these container user and user permission things is all new to me. Turns out I think it would have worked better if I had been setting up Jellyfin with a network share anyway. That makes little sense to me since the hardware is all in the box - but understanding that in the background the hypervisor is setting up a network of it’s own. makes alot more sense now.

so call it noob issues.

But you can get an adaptec…

Thank you for this updates. Specially about TrueNAS SCALE. Am also hoping to use it. let’s see

so the HBA card did flash and it does beep or did. some careful snips fixed that.

Hard drives are the HGST 3tb SATA devices 7200 RPM might as well. I have 4 in the box as Z1 pool.

I’m going to try again with truenas scale RC1. However my last test rig setup was Proxmox with a truenas core VM and an Ubuntu Linux server VM - where this VM had dockers for Jellyfin and Radarr. it worked mostly but it’s complex IMO. It works and I get the ability to have Proxmox backup and restore if I muck it up. so that is helpful I guess.

But I’m going to do another test run with Truenas Scale RC1 - we will see.

OH and I’ve got a neighbor doing this same sort of build with me.

Ram is now up to 48gb by the way.