[Guide] Remote Gaming on Unraid

Got to stream over network with Parsec client. I had resolution set to use client’s resolution. I got to play. After restarting, when starting the game, it says The host’s video resolution is too high at 3840x … My screen resolution is showing 1920x1080. My client, is also using 1920 x1080. I’ve restarted the Parsec host, the parsec client. Re checked the Parsec host settings. Whenever I start the game, keeps on saying my resolution is too high at 3840 x …

Please, how do I fix this?

Change the desktop resolution of the host in windows.

The host desktop is on 1920x1080. Checked using RDP. Nothing wrong. When running the Parsec client, a notice pops up above, saying the Host’s settings is too high at 3840 x something, but the host is at 1920x1080. I was able to use it earlier. I just left it as is, then this thing happened.

Check your client and host settings on the parsec application.

Checked and double checked, will do a triple check, just to be sure. Just to be clear, there is no SAVE button in the Parsec App Host settings right?

Is it possible to connect a monitor on the GPU, and physically check resolution, then plug the HDMI plug back?

Screenshots would be helpful, especially of the error!

There’s no save button in the parsec client.

You don’t need to plug in a monitor to check a resolution, you can switch it while you have parsec open.


config file

I made sure Bandwidth limit is set to 50 initially, and went into config file and change it to 100. Now, using remote client and went into the host, host settings show Bandwidth limit is 5, though in the config file, it still says 100.

Upon exiting the game, when it goes back to desktop, you can see icons slightly bigger, then will revert back to a smaller, regular sized icons.

Anybody with double cursors issue ?

Your setup and mine (last things will arrive monday)

  1. CPU: AMD 3700X (243€ with online discount)
  2. CPU cooler: AMD Wraith Prism LED (with CPU included but maybe going to switch for Nocta NH15s-less noice, less temperature)
  3. Motherboard: ASUS Prime X570-Pro (180€ from ebay)
  4. RAM: 64GB DDR4 3200MHz (99€ fro 1x32GB)
  5. GPU 1: Zotac RTX 2070 Super (already used for eGPU)
  6. GPU 2: Nvidia Quadro P2000 (borrowed for testing from a friend who is actually using now tesla GPU and wanna sell the card for 260€ to me)
  7. Fans: Arctic P12 PWM PST 5-pack (amazon wholesale 7€)
  8. Case: Selfmade Wood case (Tube - old desk) : front 4 Arctic PWM and Back 30cm Cooler
  9. Cache drive: 1TB Samsung Evo 970 NVMe (72€ ebay (new))
  10. Storage: 4x600 GB Dell 15k SAS 2,5 HDD (Got them for free - Need to buy PCIe SAS HBA), JBOD 3-4TB SATA 3,5 HDD
  11. VM SSD: Samung Evo 860 1 TB (already used as pen drive / usb 3.2 c to sata case)

I would like to give it a try with your build and Unraid @JDM_WAAAT
I’m gonna start building and setting up most things from tuesday night and I hope I will have the same nice running setup, that my wife and children will not kill be because I might kill their hardware / gaming / working possibility.

I have never done anything else instead of ESXi or docker, but I hope, that I can still use everything and I might can ask you for any detailed stuff like https://www.reddit.com/r/unRAID/comments/dm2phn/unraid_680rc1_wnvidia_remove_2_stream_limit/f4w9ulh/

Do I actually need the P2000 for anything else, or can everything be done with the RTX 2070s?
Thank you in advance.

for those that are using two gpu, how are you passing through the primary gpu? i have a vm with rx580 passthrough and everything is working fine. however, unraid still seems to grab the primary slot gpu(1030) and even if i use the vfio-pci plugin it wont “let it go”. set up another vm just like the first(followed this guide) and when i add the 1030 to the gpu/sound card and start that vm, the dispay goes black and then the no signal message shows up even though the vm is running. i thought that with unraid there would need to be 3 cards for passthrough of two machines and not having issues but saw/was told that two would work. also tried the tutorials by spaceinvader but not having any luck with the nvidia passthrough with vbios.

Did you follow this guide? There’s no need to use the VFIO plugin, this guide works with primary and/or secondary GPUs.

i did/have. i was curious about it so figured i would try it. hasn’t helped/hurt anything. can’t seem to get the 1030 to be used though. unraid keeps using it even when i tell it not to. the drivers show up as vfio-pci like the rx580 but every time i try to start the vm with the 1030 it just hangs and gives me nothing. so i tried to use it connected to a monitor to see if that would give me anything, still nothing. monitor goes black and then says no connection turning off.

How do you know “unraid is using it”?

since the vm with the 1030 was having issues, the hdmi dummy plugs didn’t work and neither did directly plugging it into a monitor. when i try to use parsec, it only shows up in the client side when the 1030 isn’t connected to the vm. at one point while the monitor was connected the unraid boot screen came up and went through it’s process and then when i tried the vm the screen went black and then shows no signal. so since i tried to pass it though and the vm it’s assigned to only shows up when its “gpu” is set to vnc remote, i am assuming that unraid is doing something with the 1030 and wont let be on it’s own like the 580.

Oh, well I hadn’t even considered - the GT1030 doesn’t have NVENC anyway, so you won’t be able to use it with Parsec.

for that vm parsec doesn’t really matter, figured see how it’d work. which it wont. haha. my main concern for that vm is to have the gpu passthrough so that i can have it hooked up to a monitor and controller so my girlfriend can play her games(rack is next to the desk). wanted kind of an all in one and this seemed to fit the bill over a “standard” vfio build. the only other option is to add another card and that would require building a whole new rig.

I don’t see why you would have an issue with your current setup - perhaps it’s worth trying again from the beginning?

@JDM_WAAAT could you add for you VM Setup (Guide) for Windows 10 build 2004 and above you need to disable first Windows 10 Hello before being able to save your credentials to log in independently.

faster solution if the checkbox doesn’t appear default:
cmd → control userpasswords2

1 Like

Hey all, I need some help. I can’t figure out what I am missing. I edited the XML under the VM as the guide said.


not sure what I am missing. :frowning: i can upload the whole xml

what my gfx card is listed as.

The slot and function need to match on your GPU.