[Guide] Remote Gaming on Unraid

So my VM is hung up at booting. not sure what I am missing

indent preformatted text by 4 spaces
-m 12800
-overcommit mem-lock=off
-smp 8,sockets=1,cores=4,threads=2
-uuid cb174d8c-fc06-6911-b145-29ec5a2831f3
-display none
-chardev socket,id=charmonitor,fd=33,server,nowait
-mon chardev=charmonitor,id=monitor,mode=control
-rtc base=localtime,driftfix=slew
-global kvm-pit.lost_tick_policy=delay
-boot strict=on
-device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x7.0x7
-device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x7
-device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x7.0x1
-device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x7.0x2
-device ahci,id=sata0,bus=pci.0,addr=0x4
-device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5
-blockdev ‘{“driver”:“file”,“filename”:"/mnt/disks/windows_vm/Windows 10/vdisk1.img",“node-name”:“libvirt-2-storage”,“cache”:{“direct”:false,“no-flush”:false},“auto-read-only”:true,“discard”:“unmap”}’
-blockdev ‘{“node-name”:“libvirt-2-format”,“read-only”:false,“cache”:{“direct”:false,“no-flush”:false},“driver”:“raw”,“file”:“libvirt-2-storage”}’
-device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x3,drive=libvirt-2-format,id=virtio-disk2,bootindex=1,write-cache=on
-blockdev ‘{“driver”:“file”,“filename”:"/mnt/user/isos/virtio-win-0.1.173-2.iso",“node-name”:“libvirt-1-storage”,“auto-read-only”:true,“discard”:“unmap”}’
-blockdev ‘{“node-name”:“libvirt-1-format”,“read-only”:true,“driver”:“raw”,“file”:“libvirt-1-storage”}’
-device ide-cd,bus=sata0.1,drive=libvirt-1-format,id=sata0-0-1
-netdev tap,fd=35,id=hostnet0,vhost=on,vhostfd=36
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:0d:1d:be,bus=pci.0,addr=0x2
-chardev pty,id=charserial0
-device isa-serial,chardev=charserial0,id=serial0
-chardev socket,id=charchannel0,fd=37,server,nowait
-device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=org.qemu.guest_agent.0
-device usb-tablet,id=input0,bus=usb.0,port=1
-device vfio-pci,host=0000:03:00.0,id=hostdev0,bus=pci.0,multifunction=on,addr=0x6,romfile=/mnt/user/isos/PNY.GTX1070.8192.160728.rom
-device vfio-pci,host=0000:03:00.1,id=hostdev1,bus=pci.0,addr=0x6.0x1
-sandbox on,obsolete=deny,elevateprivileges=deny,spawn=deny,resourcecontrol=deny
-msg timestamp=on
2020-07-23 12:59:41.828+0000: Domain id=4 is tainted: high-privileges
2020-07-23 12:59:41.828+0000: Domain id=4 is tainted: host-cpu
char device redirected to /dev/pts/0 (label charserial0)

@JDM_WAAAT Number 9: could you provide a screenshot where to put the code precisely? #

I was curious, what is the bios setting for the Gigabyte 7P3sh2 board? I think that is my issue.

Hi guys!

I m trying to figure our why is my parsec connection so laggy an inresponsive. Even RDP is better than parsec!..So my hardware is quite old but it should be sufficient.

M/B: ASUSTeK Computer INC. P8Z68-V Version Rev
BIOS: American Megatrends Inc. Version 3603. Dated: 11/09/2012
CPU: Intel® Xeon® CPU E31270 @ 3.40GHz (4c/8T)
HVM: Enabled
IOMMU: Enabled
Cache: 256 KiB, 1024 KiB, 8192 KiB
Memory: 16 GiB DDR3 (max. installable capacity 32 GiB)
Network: bond0: fault-tolerance (active-backup), mtu 1500
eth0: 1000 Mbps, full duplex, mtu 1500
Kernel: Linux 4.19.107-Unraid x86_64
OpenSSL: 1.1.1d
GPU: Sapphire Radeon RX570 4GB

Intel Pentium G4560 Kaby Lake
Intel HD610 GPU

I was abble to create VM with GPU pasthrough by using your guide, pc is q35-4.2. VM disk is on unassigned 256GB SSD. Connection is 1gbit wired.

Could you please take a look on my VM setting and maybe some advise what can I try. Thank you

XML file is here: LeteckaPosta.cz Sdílejte Posílejte soubory leteckou poštou - Poslání souboru - Zde nahrajte svůj soubor

EDIT: I did try to create a second VM on i440fx-4.2 with the same unassigned SSD and same GPU (I have only one), but this VM is not even loading (it starts but I cant connect to RDP or even ping it)
second XML is here: LeteckaPosta.cz Sdílejte Posílejte soubory leteckou poštou - Poslání souboru - Zde nahrajte svůj soubor

Meanwhile I find out parsec inresposive is cased by my Logitech wireless mouse. This is very strange.

Also I have read somewhere that Radeon GPU is not suitable for i440fx VM chipset… Do you have the same experience? Thank you

Just a heads up for passwordless sign in, it was different for me in Windows version 10 2004. It didn’t have the checkbox anymore.

Editing HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\PasswordLess\Device\DevicePasswordLessBuildVersion to 0 instead of 2 re-enabled this checkbox for me.

1 Like

Any tips to improve cpu performance, I have only 5800 pts on passmark with a i5 8400 using 5 of 6 core whereas normaly this cpu has a score over 10000.
I have configured cpu pinning and isolation, and emulating core is on the unraid core.
So unraid is running on core 0
VM is running one cores 1 2 3 4 5 with emulating core on 0
I’m using the last Windows 10 with 12gb, a 1660 super and 1 tb nvme.
I set hpet, i tested with and without emulating pin/core, and with and without hyper v.

Can you share your CPU pinning screen?

There isn’t a huge difference in $$ cost between i9-9900K and the Ryzen 9 3900X. Which one do you all think is better. I made two systems here, basically only difference is CPU and Mobo.


i had similar issues with parsec and my mx master. i moved the receiver closer to my mouse and the issue went away. some radeon/amd cards have a reset bug where you have to reboot the host to get the vm to grab it again. i have a rx 580 that was specific for a macos vm (supported) and because the supposed reset bug didn’t exist. under a “original” vfio build the reset bug was 50/50 on hitting. but with unraid the bug doesn’t seem to be around. not sure what the difference is. the vm for that card is also the i440fx 4.2.

i’m having issue with a gt 1030 passing through to a windows vm. i know parsec wont work with this card but it’s use case is slightly different than this guide. i’ve tried creating a vm several times with ovmf and seabios as well as if440 and q35 and i still can not get the monitor connected to it to show any output. the best i have gotten is to pass the gpus video but leave the audio not passed through and connect with team viewer to see windows. i updated the drivers and had nvidia drivers loaded but got the code 43 error.

the only thing that i haven’t tried, with success, is the xml edit. for some reason i either don’t seem to understand what needs to be changed properly or i just don’t get it at all. either way, i can’t seem to get it to work.

stock xml: win10 stock xml - Pastebin.com

modded xml:win10 modded xml - Pastebin.com

this guide is amazing!!
i already set it up and it works (have not done any gaming, but remote desktop is great)

but now i have a question regarding security: does the user for autologin have to be admin? I’m not a fan of the user beeing permanently logged in.
what is your oppinion about that?

and further on: you write that you pass through the ports for up to 10 players, but how will that work with one machine? or is that for a multi-machine setup?

thanks in advance!

Bare Metal: 7378 3DMark
Unraid VM: 6774 3DMark, lower CPU score due to reserving cores for Unraid.

This is an awesome idea. Great work @JDM_WAAAT! I am getting close to the same 3DMark scores as I was when I built this machine earlier this year. Now i’m getting more use out of the system since I only play games occasionally.

3DMark Score Compare

1 Like

Good results @Veriwind!

If you’re in the market, wait a few months for Zen 3 and see how it stacks up.

Hi there!
Very nice guide, thanks for sharing!

I use my Unraid server similar. I have a VM starting as soon as it boots.
Using it for 3D/Design work mostly so want as much CPU and GPU power as I can get (similar requirements to gaming I guess).
I have a 3900x and one GTX1070ti and RTX2070super I passthrough to the VM.

When I created the VM I enabled Hyper-V and actually didn’t extraxt my Bios. The VM is running ok. Benchmarks where promising. So I am in tweaking moode now. It feels After Effects is quite sluggish but unfortunatly the app is pretty bad anyway so I am not sure if thats my settings or Adobe.
(Coming from MacOS its really hard to tell if the performance right under Windows)

Can I ask the reason for turning Hyper-V off in the VM tab and using your edited xml? Would love to see if I can get more power. GPU are running without the Bios, is there any advantage to extracting it?

Thanks for the help!

I have to improve my Parsec setup to make it feasible to actually game with it. Currently, proof of concept done :smiley: Working. But not usable in actual, due to lag. Hardware, Xeon E5-1650 v3, with 32 GB RAM. 4 cpus pinned on to Parsec VM. GPU passed through. Followed instructions in XML. When playing NBA 2020, there are lags that make it not feasible for actual play. Actual game to play is League of Legends, which is very low in requirements. But during tutorial, it shows lag. Settings set to 1080p, Very High. Using GTX 1080. Haven’t overclocked the gpu, as I don’t think it is necessary. The game (LOL), I believe has pretty low requirements. Can you suggest where to begin troubleshooting? Using wired setup.

Just sharing my experience here…
TL;DR I was dumb and re-flashed my Unraid USB to UEFI and not Legacy :sweat_smile:

I went ahead and bought an Unraid license since I was still on trial, but I switched to a better USB drive before I did and when I re-created the flash from backup but as UEFI boot this time :sweat_smile:. That’s when things went wrong and the dreaded error 43 came on my video card. I ran through the guide like 2 more times and finally saw the green underline under “legacy” in JDMs syslinux setup pic. :man_facepalming: .

Oh well, works now!

Did you follow the experimental settings?