NASKiller Mini-ITX Troubleshooting (No video, no USB)

Over the past week, I gathered all of the parts for the NASKiller 4.0 mini-ITX Build from across the Internet. I was able to score more of everything exactly as it is listed.

  • Case: Fractal Node 304
  • Motherboard: Intel DQ77KB Mini-ITX
  • CPU: Xeon E3-1260L
  • RAM: Crucial 8GB 204-Pin DDR3 SO-DIMM DDR3L 1600 (PC3L 12800)
  • CPU Cooler: Thermaltake Gravity i2
  • Power Supply: 19V 120W DC power supply
  • SATA Card: 2 Port SATA3 card
  • 2x Seagate Ironwolf 4TB HDD
  • 1x WD Blue 2TB HDD

I put the final piece in yesterday (the RAM) after taking delivery and tried to boot up. It initially went into a boot-loop. When the power is plugged in, all of the LEDs turn on on the motherboard and the MSATA. Pressing the power would start the fans for about 15-20 seconds and then restart.

Following a thread on Tom’s Hardware on exiting a boot-loop, I reset the Intel MEBX jumper first to the Configure setting (which got me out of the loops), then to the complete reset which requires a USB with the .BIO file.

This brings me to where I am now.

When I power on, all of the LEDs turn on, the fans run as normal, I put my ear to the HDDs and they spin up (and remain active), but I see no video and have no USB for keyboard and mouse function.

There are no beeps, but I believe that I don’t have a mobo speaker right now.

Any help would be greatly appreciated! Thanks in advance!

Try booting it with the HDDs unplugged.

Also, have you tried the RAM in the other slot?

I have switched RAM slots to no avail. I haven’t disconnected HDDs yet. I assume I would leave the MSATA in? I’ll try this evening and report back. Thanks!

Still nothing unfortunately. I tried normal operation without HDDs connected as well as trying to configure and reset the MEBX jumper.

Any additional ideas.

The fans run, the LEDs all turn on. Just no video or USB functionality for the keyboard and mouse.

I’d pull all the ram, expansion cards, drive connectors and everything from the front panel sans the power switch and work forwards from there. Probably would be nice to have a speaker hooked to the mobo if it has the capability. Work the post codes as you encounter them. Try a new bios battery too.

This morning I disconnected all the HDDs and just left the RAM, CPU and MSATA in the mobo and disconnected the CMOS battery based off of forum posts I’ve read elsewhere about other computers turning on but not going through boot. I’m going to leave it until probably Friday to make sure everything is reset and then start from there.

So, I may not respond until Friday. Thanks for pitching in with your advice. I might buy a new CMOS batter since they’re only $7.

I’ve also gotten in touch with the seller who’s first quest was what CPU and RAM I’m using with the mobo. I’m glad he/she responded and with good directional questions. We’ll see what happens.

How are you actually verifying this isn’t booting? My Intel DQ77KB makes zero beeps when it boots. What are you using for video out to verify that it isn’t working?

That’s actually a great question because I am assuming that the video out is through the onboard HDMI port on the motherboard. Now that I’m reading more in the documentation (because of your questions) I’m reading about the Intel Flexible Display Interface (FDI).

What are you using for video?

EDIT: As I’m looking this up, I may be starting to feel like an idiot over here. The FDI uses the DisplayPort (which is next to the HDMI port on the motherboard). Am I safe to assume that HDMI is not the default port for video out on boot?

I had a motherboard do the same thing and confirmed either the cpu or motherboard was dead. I was getting no beep code, no hard drive activity and not even a no ram beep code when I removed the ram. (According to my motherboard’s manual, there’s a beep code for that’s)

Moral of the story you could have a dead CPU or motherboard. I could be wrong though.

I can see that. However, my HDDs spin up and run. It definitely seems like the computer is running normally, I just don’t have video or USB. Which is why I am leaning towards the mobo. It’s hard without any beeps.

@COZisBack Can I get a confirmation that you use the DisplayPort (not the HDMI)? I checked out adapters and I’d like to make sure that HDMI isn’t a valid option for booting before dropping money on an adapter or new cord.

Thanks to everyone for their advice! We’ll get this sorted out!

I used HDMI when I originally configured. I wanted to make sure you weren’t using adapters. I’m not sure if you’ve tried building outside the case already, but I would try that with only 1 of each of the necessaries plugged in.

If you’re still not working then, call the seller and let them know the issues you’re having and the troubleshooting you’ve done.

1 Like

The seller has been amazing and has offered to replace the motherboard after testing to make sure the new one is operational.

Despite the issues with the motherboard the experience with this seller has been off the charts and I’m looking for ways todo more business with them, throw them more business and write a much more glowing Feedback.

I’m glad I didn’t make the impulse buy of that DisplayPort to HDMI adapter yesterday.

Can’t wait until this is sorted out and I have a functional server.

1 Like


The seller sent along the processor (an Intel i3) with a new board today. I did an open desk build with minimum components (heat sink, MSATA drive and RAM). It worked flawlessly!

On a hunch (and since I still had my original Xeon processor), I swapped the i3 for the Xeon and it too was successful! So, I loaded up the rest of the hard drives, did some cable management and was able to install FreeNAS pretty easily!

I’m going to send back the i3 with the defective board tomorrow. So, all ended well! I’m up and running and was able to build a pretty stellar NAS using the NASKiller 4.0 Mini ITX Build!

Thanks to all of you for your advice, help, etc. I really appreciate everything!

1 Like