[Guide] Updating your LSI SAS Controller with a UEFI Motherboard

Hi guys. Got an IBM Serveraid M1115. Can I use this guide for flashing it to IT mode?

Thank you, OP.
Your guide worked perfectly on my LSI SAS 9211-8i paired with a ASUS Prime Z370-A LGA.

So this one is a little different, I’m using a 9200-16e and I have had it inside of a HighPoint 6661A enclosure for several years now using it over Thunderbolt 3.

I just upgraded to a new machine that has Thunderbolt 4 and I can’t get Windows to acknowledge the device exists. I can see the HighPoint in Thunderbolt Control Center, but not the SAS card.

It has signed UEFI P20 in it. Any ideas from anyone? It works great on my older TB 3 machines.

I have no idea. Wish I could help somehow.

Is there any reason not to use the Windows installer if it’s available for your card?

The Windows installer works for updating a similar type of firmware (IT → IT or IR → IR) but does not work for reflashing, such as IR → IT.

1 Like

Makes sense, thanks for the info

Used this to update my 9200-16 card to firmware version 20 yesterday. Worked great. Thanks for the guide!

1 Like

Thanks so much for this guide! worked perfectly on flashing my LSI SAS2008 embedded board on a Tyan S5512.

1 Like

Thank you so much! Was just able to update my 9207-8i - had been stuck for months.

1 Like

I just called (registered) to say… I love you (this was SO easy compared to all other docs online).

Today, you are my hero.


Welcome to the community! :slight_smile:

1 Like

Hi, wondering if anyone can help me. Have upgraded as per the instructions above on my 9207-8e and am now getting a NV Ram error and cannot go any further, have looked online for hours now.

First tried via Dos, no go - my asus motherboard won’t have it, getting a PAL error, ok i thought I would try efi next, installed all good (felt great while it lasted :slight_smile: ) and then I get this error. dont know what to do next. Any ideas??? Thanks

Give us screenshots of the errors you mentioned and we might be able to help

Thanks for getting back to me.

The commands I have tried are:

sas2flash -o -f9207-8e.bin -b mptsas2.rom
sas2flash.efi -o -f9207-8e.bin -b mptsas2.rom

sas2flash -o -f9207-8e.bin -b x64sas2.rom -b mptsas2.rom
sas2flash.efi -o -f9207-8e.bin -b x64sas2.rom -b mptsas2.rom

i dont know if I am using the wrong .bin?? I have run out of ideas

Thanks, great community, very friendly and helpful.

Thanks for this, it solved an issue I was having getting a Supermicro X11 based system to boot in UEFI mode.

One question however, how do you access the configuration utility once in EFI mode?

I now get an extra option in my BIOS ‘Advanced’ menu titled “LSI SAS2 MPT Controller” but inside this there is only a very simple set of options, no way to list drives on the bus, show topology etc. How do I get back to the application that you’d normally see when pressing ‘CTRL+C’ in the legacy bios version?

Hi. I tried to follow the steps above for a LSI 9211-8i. After I get into the UEFI shell, I have tried the sas2flash.efi -listall command and always get the following error:

No LSI SAS adapters found! Limited Command Set Available!
Finished Processing Commands Successfully.
Exiting SAS2Flash.

I have tried a couple of times on two different computers. Is there anything specific I need to check. Or does this seem the controller is dead? I have tried in a Gigabyte B365M DS3H and an Asus B450-F. I appreciate the help.

What about LSI SAS9212-4i4e? The SAS2008 firmware should work with that shouldn’t it?

dmesg | grep LSI
[ 2.140729] mpt2sas_cm0: LSISAS2008: FWVersion(, ChipRevision(0x03), BiosVersion(

Question, any way to verify what mode a card is operating in via Linux? Or should I just setup a bootable EFI disk and check using that?

I believe my card is an IBM variant… FRU: 46C8935.