[Guide] Remote Gaming on Unraid

Hey JDM_WAAAT, Awesome guide.

hoping someone can help. Ive followed it up until I edited the syslinux.cfg and rebooted the server and it would throw this error while Unraid was loading.

I have attatched a screenshot of my IOMMU Groups as well as Flash Config.

If anyone has any idea of where to go from here or what could be causing the issue, any feedback would be appreciated.

Thank you,

Not trying to resurrect this old post, but I have been using the True Bridge mode using netgraph. This completely bypasses the ATT router and pfsense is connected directly to the ONT. Everything is here: GitHub - MonkWho/pfatt: Enable true bridge mode for AT&T U-Verse and pfSense (this is a fork of an original repository https://github.com/aus/pfatt. Since it is not available anymore, I'll do my best to maintain a copy for people that still need a bypass) and there are additional steps if you have uverst tv.


To set the scene, im completely knew to servers as a whole. Apologies in advance for my ignorance.

I have ready the OTIS post and this…

My goals:

  • Small server case
  • For plex use (4/7 simultaneous transcoding)
  • Parsec gaming (No need for ultra high settings)
  • Budget: £500/£700
  • Want everything in one case
  • I want ideas on what hardware to get

My current set up:

  • WD external nas
  • 2011 Mac mini as the plex server

I like the sound of this, even though i don’t know if it can game too:
|Motherboard|ASUS Prime Z390-A|1|$129.00 |
|CPU|Core i7-9700|1|$320.00 |
|RAM|OLOy 2x16GB|1|$120.59 |
|SSD|Sabrent Rocket Q 1TB|1|$119.98 |

hey i use moonlight and can´t see a mouse cursor… on onraid there is not a mouse on usb… is a server… how i could it resolve on win 10?

First post here at serverbuilds…pretty cool looking place. I was googling trying to figure out how to remote into my W10vm from a ShieldTV to play games and standard productivity on the TV. I saw on the original post it mentioned the Shield TV as a client but I couldn’t find any specifics. My pass through GPU is a AMD card so I cant use the GForce stuff, nor the Moonlight.

Has anyone with a Shield tried something like Splashtop on Shield to log into W10VM and does it work well for gaming and controller use?

I’m not sure what all options there are…doesnt seem like very many at all.

Thanks! Cant wait to check this place out!!!

1 Like

Hi guys, first post here as well and finally decided to jump into unraid and getting my parts together. I have been doing a bunch of reddit, reading, youtube videos, unraid forum, and LTT forum readings. Also went to chat with some technical experts but could not get consensus:

My ideal parts:

  • Ryzen 3900X or 3900XT
  • Gigabyte Aorus Master X570 - got it
  • 4 x Corsair LPX Vengeance 16GB 3200Mhz memory - got it
  • Nvidia 3080 if an when it is available
  • 2 x WD SN750 black 1TB NVME - got it
  • 4 x Seagate Baraccuda Pro 10TB - got it
  • Fractal Design 7 casing - got it
  • Corsair H1000x or H1200x (out of stock - would 1000w be plenty enough?)
  • The recommended HDMI dummy plug - got it
  • Samsung 32GB bar USB as recommended - got it

Use case:

  • W10 Gaming VM (would I even be able to run FS 2020 inside a VM as an example?) with 3080 GPU passthrough (6-8 cores)
  • Emby Docker with HW transcoding through the Ryzen 3900X CPU - 2 to 3 1080p transcoding from HEVC source. Maybe 1 to 2 4K transcode from HEVC source.
  • Radarr, Sonarr, Jackett, Transmission dockers.
  • Rsync with remote NAS to do offsite backup on some data
  • PieHole (never tried it yet)
  • VPN Server
  • Automated photobackup from IOS and Android devices

I stated the details above as my questions below could not get any clear answers:

  1. Would a Ryzen 3900X Unraid build (such as this guide has detailed), produce a reasonably stable system? Or would swapping over to an Intel 10900K produce longer uptime? I have heard INtel 10900K is easy to setup but also heard many successful Ryzen builds.

  2. An Intel 10900k will allow me to use QuickSync for Emby/Plex encoding but I was recommended to get a dedicated GPU for transcoding (GTX 1660 or higher). Would Ryzen build with dual GPU relatively easy to setup? I have seen LinustechTips recent Youtube video on his couple’s gaming PC and he could not get a dual GPU Ryzen system to work - which is worrisome - https://linustechtips.com/main/topic/1245279-we-made-the-perfect-couples-pc/

  3. Any chance (hopefully from JDM_WAAAT) on a Ryzen DUal GPU guide? Or someone point me to the right direction to start reading more?

Thank you for any feedback.

I’m not an expert with everything but thought I’d mention one thing. IF I was going to buy a seperate GPU just for Plex then I’d probably go a different route…I’d get a Shield TV and connect it to all of your media (media stored on Unraid server). This way your server is storing everything and has all the space, but the Shield TV is handling all the processing work. The shield has excellent video capabilities as well as excellent transcoding capabilities.

I did this so that it would take that load off my server resources so that I could dedicate more resources to my W10vm for gaming. Gaming hits the GPU and CPU hard and when you throw Plex into the mix at the same time your going to struggle…even with two GPU’s.

The latest Shield TV Pro is $200 so cheaper than a good GPU.

Thats just my opinion…I have a Shield and its tied to my Unraid server…works awesome and also brings a lot of other capabilities to the system.

Thanks for the suggestion.

I do get the idea of using a powerful android box to avoid transcoding.

My local clients currently use amazon 4k stick and fix enough to stream 4k hevc.

What I like to do is to stream remotely some transcoded 1080p videos 2-3 streams. My qnap nas is struggling and can’t keep up so going a fast server with it without gpu can handle this.

Which the included gpu can be use for remote having…

Plus I have some use for docker and other vm so I am stoked to try it…

when I update my graphics option to my GPU and hit update, then go back into edit VM, it has reverted to VNC. This is even before going into the XML view. I have my xml attached

<?xml version='1.0' encoding='UTF-8'?> TEST 457a0b48-fc48-4ec4-626e-42302f16ad99 4194304 4194304 12 hvm /usr/share/qemu/ovmf-x64/OVMF_CODE-pure-efi.fd /etc/libvirt/qemu/nvram/457a0b48-fc48-4ec4-626e-42302f16ad99_VARS-pure-efi.fd destroy restart restart /usr/local/sbin/qemu

Were you able to resolve your issue?

Nope, I was able to do it once. not sure how. but I kept getting the code 43 error, and the graphics card wasnt putting out the vm to my monitor. I figured it was because I’m running a z490 and 10700k and unraid isnt ready for this yet. IDK I installed windows and Im gonna put unraid on my older system. My preference would be to run it on my main, since I have 64gb ram and a good cpu.

Is my assumption that the most modern mobos and cpus might not work with the current unraid? I couldnt even get the stable to boot on it, had to use the beta

No, it should support everything just fine.

I followed your guide to a T, (other than the BIOS setup). I am running the MSI z490 MoBo. When I disabled UEFI boot, I was not able to boot any devices. I flashed the most current BIOS, and still no luck.

When Running UEFI, I am only able to boot the Beta Unraid, and was not able to boot stable. (I plugged the stable into an older system and was able to boot fine.

I followed all of the steps and the furthest I got was connecting via RDP to my vm which supposedly has my 1080 passed through, but then I get the error in device manager regarding my GPU. So I revisited the steps regarding editing the VM’s XML and BIOS passthrough, repeated multiple times to no avail.

I would love to make this work on my primary system. I have been pulling my hair out, and keep going back to the possibility that there is incompatible hardware.

You need to turn off UEFI boot in the Flash drive as specified in the guide and then turn it off in the BIOS. After that, select the proper boot device and it will be able to boot.

Your hardware is compatible, your GPU issues are likely stemming from the fact that you are booting in UEFI, not Legacy mode.

I have the same issue as RexSpecs had. After the initial windows install i can no longer switch GPU from VNC. Only add as the second.
Im using unRAID 6.9 beta30.
Specs: ASUS X470-PRO – Ryzen 2600 – AMD 5700 XT
Everything went perfect up this point.
Worth a note is that this is not a problem on a linux VM I have, there I can switch between a GPU or VNC with no problem.
I have also double checked that it is booting in Legacy mode and not UEFI, though this does not appear to matter.

Delete the VM config, and create a new one with the appropriate GPU config using the old vdisk. I think it’s a new bug in unraid.

Thanks for the very fast reply, worked like a charm!

1 Like

Ran into another issue. During the install of the GPU-drivers the screen went black (For ever, not the regular blinking). Stopped the VM and now it freezes during boot with one CPU core maxed out.
Should I just try reinstalling the VM?

EDIT: This was resolved my installing the VM with Q35 instead.

I added two unassigned HDDs to my VM with passthrough, but I had to do it through the XML interface.

Here is the code I used:

<disk type='block' device='disk'>
  <driver name='qemu' type='raw' cache='writeback'/>
  <source dev='/dev/disk/by-id/XXXXXXXXXXX' index='1'/>
  <target dev='hdd' bus='virtio'/>
  <alias name='virtio-disk3'/>
  <address type='pci' domain='0x0000' bus='0x01' slot='0x01' function='0x0'/>
<disk type='block' device='disk'>
  <driver name='qemu' type='raw' cache='writeback'/>
  <source dev='/dev/disk/by-id/XXXXXXXXXXX' index='2'/>
  <target dev='hde' bus='virtio'/>
  <alias name='virtio-disk4'/>
  <address type='pci' domain='0x0000' bus='0x01' slot='0x02' function='0x0'/>

I used an entirely different PCIe bus that my other devices. Note that the alias name, target dev=hdx, and slot=0x0x musy be unique.