[Guide] NAS Killer 6.0 - DDR4 is finally cheap

What unbuffered ECC memory did you use in the X11SCA-F ? I will be using my build for TrueNAS Scale.

I found out my registered ECC memory does not work with this motherboard.

I ended up buying Micron DIMMs new from Crucial: Micron 32GB DDR4-3200 ECC UDIMM 2Rx8 CL22 | MTA18ASF4G72AZ-3G2R | Crucial.com

Not sure if it still works but at one point you could get 10% off using the code “CRUCIAL10”

However any DDR4 Unbuffered DIMMs rated for 2666Mhz or faster should work with the board.

I would prefer to have found something cheaper used, but at the time that was just the least expensive Unbuffered ECC memory I could find.

Thanks for the link. The discount code still works but a bit different format: 10CRUCIAL

Hey, just putting together a parts list for a build following this guide. I noticed the “suggested” motherboard X11SCQ in Motherboards for sale | eBay is now going for $230 on ebay (vs the $75 it’s priced at in the guide). Is there a reason its price jumped up so much? Should I just look for a different board in the list in the OP? Or scrap the entire OP list and look for my own?

You should look for a different board.

It would be a reasonable deal at $75, but there is nothing particularly special about the board and no reason to pay more than other Socket 1151 V2 boards. The main criteria should be that it supports 8th / 9th gen Intel processors and has enough SATA ports and PCIe slots for your needs.

The step-up board the Supermicro X11SCA-F is more consistently available at $100, but if you don’t care about ECC memory or IPMI then just get the least expensive Socket 1151 V2 board you can find that meets your needs.

This is an interesting option as well. Probably will stick with Crucial since they are a reliable brand. I have purchased other items from Unix Surplus in the past and their customer service is great.

That RAM should work just fine. Samsung is a top tier memory producer.

I think you probably won’t go wrong with modules produced by Mircon, Samsung, or SK Hynix

Hey, wanted to share the final result of my home lab server built using the guide. Thank you so much for the work and helpful information!

Everything was purchased used from eBay Germany, except for the Crucial SSDs. The NVMe’s have been bought used as “new” aka package opened but never plugged in.

  • Supermicro X11SCA-F
  • Intel Core i5-9500
    • Scythe Mugen 5 (Rev.B)
  • Crucial Pro DDR4 RAM (4x32GB)
  • 2 x Crucial MX500 250 GB, SSD
  • 2 x Samsung SSD 980 PRO 2TB
  • Adaptec ASR-7805 1G SATA/ SAS Card Raid
    • 5 x 10 TB HGST He10 12Gb/s SAS HDD
  • Corsair RM750x 80 PLUS 750W
  • Fractal Define R4 Midi Tower
  • 4 x Arctic P14 PWM PST


Hi everyone,

I’m looking to build a dedicated home server for two main purposes:

Media Server: I want to store all my family photos, videos, and albums on this server for easy access and sharing within my home network.
Archiving: I’d also like to use the server to archive content from a few websites and YouTube channels using Python scripts or similar tools.

Budget is between $400-$850 (without HDDS)

I live in Overseas, buying in USA and shipping to my country is possible only through forwarding companies (in most cases). This makes parts even more expensive for me.

my requirements is ECC Support, Intel Quick Sync, as newer as possible, low power consumption, Hardware “Space” for Future Update/Virtualization, Docker Containers.

Can you suggest me hardware?

I bought this from Amazon new too, and it has been working without issues, a little more money but next day shipping in my case :slight_smile: Just so you have another option.

1 Like

Has anyone successfully aggregated both LAN ports on the X11SCA-F while maintaining IPMI access?

When I aggregate both NICs in my UniFi switch, the IPMI interface becomes unreachable when the system is off. After I manually start the system, everything functions well: IPMI is accessible, and the bond works since I can disconnect any cable, and the OS is reachable.

Btw, as soon as I disable the port aggregation, IPMI becomes available.

@lvl1featur3s Have you checked the first post? It has plenty of suggestions which hardware makes sense. ECC only works with an XEON or i3 series Intel CPU. The motherboard needs to support it too.

Turns out, the X11SCA-F does not support port aggregation. I contacted Supermicro support, and they confirmed this information.

Has anyone seen the linked stuff from Rhino Technology Group actually in stock? I know the build is ~6 months old now, but that $9 Adaptec HBA is a great deal considering everything else is 4-5x the price.

Hi all, I have the NAS Killer up and running stable now with UnRaid 6.12.8, but I am not able to get Plex or Jellyfin to use QuickSync, I had tried pretty much all dockers I had found in the apps store and no luck.

Has anyone got it working with any Docker containers?
If you did, do you mind sharing the procedure?


Is the Jellyfin container running Privileged or Unprivileged? Ultimately you don’t want to run it Privileged, but you could try running it in Privileged mode temporary just to see if that gives you access to Quick Sync as a first troubleshooting step.

Not sure if this is actually what your issue is but maybe it will help:

An Issue I have run into before is when the OS used as the base for the container has different group Ids for the various groups than the host OS. Plex / Jellyfin expect the devices in /dev/dri/ to be in the group “video” but because of a container / host group id miss-match they end up belonging to some other group.

Try running the command:

ls -alh /dev/dri

And see what Group the video devices like “card0”, “card1”, and most importantly “renderd128” are in. if they are not in “video” that may be your issue.

Technically you can configure the container to map the group id to match the host OS, but that turns out to be surprisingly difficult and I have never actually successfully done it. An easier approach is to just add the Plex / Jellyfin user to whatever group the Container thinks the devices are in.

Also get the intel_gpu_top plugin which will give you the intel_gpu_top command line tool which is helpful to determining if your iGPU is being utalized as expected when you transcode your video streams.

Hi and welcome to Server Builds!

You are on the right topic for hardware recommendations. At the top of this thread are the hardware recommendations for the current build: the NK 6.0. The pricing may be higher where you are than is listed here. If you can be a little more specific about what country you are located in there may be other members on the board who can give you local recommendations.

Since ECC support is one of your requirements you will need to get an motherboard based on the C246 chipset. This will most likely be the Supermicro X11SCA-F which is widely available from eBay sellers based in China for about $100. Here is where I got mine: https://www.ebay.com/itm/295930094644

Besides SuperMicro, Asrock and Asus also make server / workstation oriented motherboards using the C246 chipset but those tend to be more expensive and SuperMicro is higher quality IMHO. Fujitsu also makes excellent server boards, they don’t tend to be available in the US, but perhaps they are in your country.

Also for ECC support you will need either an 8th / 9th gen core i3 or a Xeon. Given your price point you will likely need to go with a core i3 such as the i3-8100, i3-8300, i3-9100, or i3-9300 unless you are able to fine a good deal on an E-2100 / E-2200 Xeon.

1 Like

Thank you for that! It helped a lot!
Just to clarify something, the pin comes enabled and for me to work it had to be move to pin2-3 (disabled).
Also a little change on your BIOS config:

  • Chipset configuration
    • System Agent (SA) Configuration
      • Graphics Configuration
        • Primary Display: PCI
        • Internal Graphics: Enabled
    • PCIe/PCI/PnP Configuration
      • Onboard Video Option ROM: EFI

But thank you, because I was looking for the setting in the Bios for a long time without luck.
Now I got it working.

Hi @Ian, yesterday I was not able to see the renderD128 when I ran your command, now that I enabled the HDMI port I can see it and it is in the group “video”

root@NASty:~# ls -alh /dev/dri
total 0
drwxrwxrwx 3 root root 100 Mar 23 11:38 ./
drwxr-xr-x 16 root root 3.5K Mar 23 11:38 …/
drwxrwxrwx 2 root root 80 Mar 23 11:38 by-path/
crwxrwxrwx 1 root video 226, 0 Mar 23 11:38 card0
crwxrwxrwx 1 root video 226, 128 Mar 23 11:38 renderD128

I am goign to install the “intel_gpu_top” and try again.

I finally got Plex to work and use iGPU to transcode instead of the CPU, the i3 that I am using can transcode at least 2 streams, but the CPU was pinned to 100% and there were dropped frames. That being said I built this killer nas with the idea of using the iGPU.
After weeks trying, I finally got it working with the linux server docker container.
First I had to enable the HDMI port and connect it to a monitor (will buy the hdmi dummy plug soon). After that the renderD128 finally showed up under /dev/dri.
To get plex working it was as easy as adding an extra argument to the container, that is done via “Advance view”:
Screenshot from 2024-03-23 13-42-08
At that point the “Extra Parameters” will show up and add this to it:
--device=/dev/dri:/dev/dri as it show in this pic:

That is it! Save the changes and start the container!

This are some outputs from my plex and the CPU/GPU usage:
Screenshot from 2024-03-23 13-34-37

Now my next step is to also get it working on Jellyfin!
I hope this will help someone else.