[Guide] NAS Killer 6.0 - DDR4 is finally cheap

Keep SATA SSDs off the HBA

Need a sanity check. Is there a reason these two HBAs are priced so differently, despite being (to my eye) exactly the same?

  1. LSI 6Gbps SAS HBA P20 9211-8I IT Mode ZFS FreeNAS unRAID +2* Cable 8087 SATA | eBay

  2. LSI 6Gbps SAS HBA LSI 9240-8i = (9211-8I) IT Mode ZFS FreeNAS unRAID + 2* Cable | eBay

FYI my motherboard is a Supermicro X11SCA-F

I think you should be good with all those components on that board. Sometimes a board will share PCIe lanes between, say, a PCIe slot and an M.2 slot, but this is a small enough board with few enough connectors that I think everything gets its own dedicated PCIe lanes. At least the Super Micro product page doesn’t mention any shared slots.

I second stuffwhy, connect the SATA SSDs to the SATA ports on the motherboard and use the SAS HBA for the SAS Array Drives.

Good luck with your build and enjoy your new server!

an ITX board is unlikely to share PCIe resources in a way that would disable any given device mostly because there aren’t all that many slots or devices on the board. Without researching it more closely, it seems like it should be ok in that respect just on assumption.

however, you should probably seriously consider a larger format build. we rarely recommend going itx/reduced footprint case because it’s more expensive in certain areas and leaves little to no room for potential expansion but doubly so since you’re building this from the start and it’s already completely maxed out.

also it’s not an NK6, NK6 is based around 1151-2, 8th and 9th gen, but, we’re here already and this far in.

Those cards should be functionally identical for you since you will be using them as straight HBAs in IT mode anyway.

I think one is a Raid card that was flashed to IT mode and the other was just an HBA from the Factory with no Raid capabilities. They both have the same controller (LSI 2008).

Physically one card has the SAS connectors oriented out of the top of the card and the other has them coming out of the back of the card. Check your case layout and see if one orientation would be better for you in terms of building the server or cable management. If not then just get the one that costs less.

Stuffwhy:

Yeah, I ran into the LGA 1151-1 vs LGA 1151-2 issue (6/7th gen vs. 8/9th gen). Decided to go with the Kaby/Skylake version because I could find much better (cost and choice) motherboard options (from what I have seen lately 1151-2 MBs on ebay have gone insane in terms of price)

Ian

It does look like the SATA0 and the mPCIe slot share a lane when the mPCIe slot is used as an m-SATA device, but I should be OK since I’m using it for (another) network card instead. If I get a conflict, no big deal: I’ll have 3 SATA devices to connect and 5 SATA ports on the MB (so if I can’t use SATA0, I’ve got other options).

Thanks for the responses guys. I really appreciate the ability to bounce things off knowledgable folks on this site. Thanks for all you do!

Could you point out which is the RAID card and which is just a HBA i.e. link 1 = , link 2 = ? Sorry for asking but am new to this

Actually I did a quick google search and it looks like they are both Raid cards.

According to the Ebay listings they have both already been flashed to IT mode so they should be functionally identical for your use case. They use the same controller and the different model numbers 9211 and 9240 probably indicates that the 9240 had some additional Raid features that you won’t be using anyway.

Thanks for clarifying! So by the sounds of it, the “raw” version that I’d want to look for (if not flashed to IT mode) would be the 9211, but since they both are flashed, the 9240 will be functionally the same.

Well the 9211 would also need to be flashed to IT mode.

For your purposes these cards are the same. In fact I think all LSI cards with the 9200 model numbers are basically same once they are flashed to IT mode.

You can probably just look at the part of the model number after the dash to decide what fits your needs. The number is how many ports and the i or e indicates internal or external connector. So 9211-8i supports 8 internal connectors, 9211-8e supports 8 external connectors, 9211-4i4e supports 4 internal and 4 external connections, etc.

Get the one that either has a better cable orientation for your case, or which ever one costs less.

Hey guys hoping you can help me out with an issue

TLDR:

I do not get video output on boot. Error codes seem to indicate no issues.


Parts List:

CPU: Intel i5-9500
Motherboard: Supermicro X11SCA-F
Memory: 4x Silicon Power Value Gaming DDR4 3200MHz CL16 16GB
Storage: 2x HP EX900 Plus 1TB NVMe PCIe M.2
PSU: EVGA 500W1
HBA:Adaptec ASR-7805 SAS2 (40mm fan attached and 1GB cache removed as per linked overview)

Let me know if for some reason other parts are needed for trouble shooting.


Trouble Shooting:

I am somewhat a novice at PC building with only 1 other build under my belt so I may not have done enough here. When plugging in either an HDMI or a DisplayPort cable into the motherboard ports no video is outputted. The monitor detects that it’s been plugged in. The monitor normally works fine, I use it regularly. I can also confirm the HDMI and DisplayPort cables are functional. On boot, the monitor will never stir, but if I disconnect the pc from power the monitor will notice. I believe the issue is based on the motherboard as there is no dedicated GPU, although the CPU should have integrated graphics. So I assume the video ports should be functional as is?

I found the Supermicro X11SCA-F manual online and will link it here. Pages 61-62 go through the trouble shooting for No Video but to be honest it’s not very helpful. As far as error codes, as far as I can tell there is no error, it beeps a few times quickly for the number of USB devices I have attached and then will give one beep for what I assume is system normal. Beep error codes can be found starting on page 104 (Appendix A).

To be safe I tried to remove as many components as I could and tried to run the pc again and I would get error codes as expected, when removing all memory I would get 5 beeps with 1 long beep at the end. With memory replaced I would get the same beeps as with everything plugged in.

When booting pressing the F11, F2, and Delete keys do not cause any visual difference. I assume one of them is actually getting me to the UEFI screen but since I get no video I can’t be sure.

As far as I can tell from the manual, the LEDs all indicate things are working properly (page 16), but I may be wrong. If a video would help let me know!

Hi and welcome to serverbuilds.

It is possible that the video out is defaulting to the VGA port connected to the BMC. You may need to get into the bios to change the default video device to be the iGPU instead of the PCI VGA device. That is just a guess though. If you have a VGA monitor or a VGA to HDMI adapter you could try connecting to the VGA port and see if you get video out that way.

The good news is that the the “-F” in X11SCA-F means that it has IPMI. Are you able to get into that? Once you are in the IPMI you can fix the video out issue, but really once you are in the IPMI you can just control the system from a web browser and not even bother with video out.

How to Connect to IPMI

Connect the i210 nic “Lan2” (the black one) to your network and the BMC should get an IP address via DHCP. You can log into your router and check the “DHCP Leases” section (or something like that) to see the IP address it received. Once you have the IP address you can connect to that IP address in a web browser and you should get to the login screen for the IPMI. The default user / pass is ADMIN / ADMIN. If you are lucky you will have access to the IPMI and you can remote control the system.

If the password is not the default then you will need to boot an OS and use Supermicro’s IPMI Tools to reset the password. Here is a guide on that.

Thanks Ian, this worked like a charm!

In case someone else ends up in the same pace I did, Ian’s instructions got me to the finish line. Plugging the pc into my network via Ethernet port (the black Ethernet port marked BMC, not the red one). After booting the pc again I was able to find the pc on my router’s connected devices list. Like Ian said, simply type the IP address of the pc into a browser search bar (I got a warning that Chrome was necessary over Firefox, Brave worked fine though) but once I went I to the site I was able to access the board through the IPMI.

Within the browser menus was an option to remotely control the pc under “Remote Control” named “iKVM/HTML5”. Using this allowed me to connect to the pc over my browser and I was able to enter the bios menu to mess with the settings.

I never found a setting specifically labeled VGA for video output or anything, but under the “Advanced” menu → “Chipset Configuration” → “System Agent (SA) Configuration” → “Graphics Configuration” I found some options that I played a little bit with.

Under “Primary Display” which was set to “Auto” I switched it to “IGFX” and under “Internal Graphics” I switched to “Enabled” from “Auto”.

Considering I don’t have a dedicated graphics card in this build I’m a bit surprised auto didn’t automatically try the integrated graphics, but the HBA is taking up a PCIe slot so maybe the computer was just defaulting into that for some reason. Regardless, after reboot I got video on my HDMI cable so success!

But Ian is right, you could do everything from the browser if you wanted, I just had a personal grudge against the pc this time, and just in case someone else is stubborn like me hopefully this will help you out.

Thanks again! Excited to have a NAS, this guide helped a ton.

That’s Great! Glad to hear that worked.

IPMI is pretty great isn’t it? It is one of those things where before you have used it you don’t really think you need it or at least wouldn’t pay more for a board with the feature, but once you have it you never want to go back.

Enjoy the new NAS!

1 Like

Hey everyone. Im starting a NAS killer build. I am green to builds, as in this is my first build of any kind, so apologies for any ignorance or glaring omissions on my behalf.

I’m getting error beeps for memory and wanted to ask a quick question. I’m going with the Supermicro X11SCA-F ATX motherboard for the added space, and I’m using the Silicon Power Value Gaming 32GB DDR4 RAM. Im getting memory error beep codes.

During assembly, I grabbed the manual for the motherboard. The section on memory errors indicates “Make sure that you are using the correct type of ECC DDR4 UDIMM modules recommended by the manufacturer.” Are the collective we certain that this motherboard is compatible with non-ECC RAM?

Again apologies if this is an amateurish question, Im just going down the list of issues as best I can here. Thank you again.

On a personal note, Ive been slowly gathering parts (mostly HDDs) for a long time and this build is a life saver. Everyone here is super kind, helpful, and respectful and I am very grateful.

What CPU are you using, by chance?

Hi everyone! I read the guide and wanted to try out making my own NAS Killer 6, but I wanted it rackmount.

I found a Supermicro CSE815 with a X11SSW-F with a E3-1260L v5 for about $150, very close to what’s in the build, and was wondering a thing: the board only supports up to Kaby Lake Xeons, so no 8th gen, and my CPU doesn’t have a GPU. Is it worth it to go to a 1245 v6 with the 630 iGPU?

This will be my NAS, my backup server (onto which also my cloud backups will be stored) and will also be the NVR. However, it will only be the storage, as the main router (with an N305 and 2 corals) will run the docker with Frigate in it.

Ideally, adding the GPU I’d like to do something like this:

  • Record in realtime using the N305’s GPU as a decoder from the camera outputs and the coral, recording to the CSE815 chassis.
  • Playing back and exporting using the CSE815’s GPU as a transcoder when needed.

What do you think?

Have you tried sourcing parts from the guide? You’re not really gaining anything by going for a Xeon. Generally they are more expensive and lack features like the iGPU, as you have noticed.

Intel Core i5-8500T SR3XD 2.1GHz

The board states that it takes non ECC UDIMM and the i5 CPU doesn’t support ECC memory anyway so the combination should be fine.
Should.
How about trying a clear of the CMOS and seeing if that does anything for you