GA-7PESH2 BMC Recovery

I just wanted to write down by experience recovering from a failed BMC firmware upgrade.
The board lost power when I was upgrading the firmware and was completely dead after that apart from the BMC led.

This is what ended up working.

UART cable
Ethernet switch or crossover cable
TFTPD32 → TFTPD64 : an opensource IPv6 ready TFTP server/service for windows : TFTP server
BMC Firmware →

Start TFTPD32 and set the TFTP root directory (example c:\tftp)

Extract the firmware zip file and copy the \235\fw\235.img file to the tftp directory and rename it to all.bin

Connect the TFTP server and the management port of the GA-7PESH2 to a switch or directly with a crossover cable

Set the IP address of the TFTP server to

There is a 4 pin UART header for the Aspeed AST2300 SOC located next to one of the 16X PCI-E slots

Connect the UART cable to the pins.
VCC is not needed

Connect Putty to the com port of your UART cable with baud rate (speed) 115200

Connect power to the GA-7PESH2 board and repetetly press the enter key on the putty console until you get to the uboot console.


U-Boot 1.2.0-g781ea2e0-dirty (Sep 14 2015 - 14:30:45) Avocent (0.0.28) EVB

Board: AST2300
DRAM:  128 MB
Flash: Bank (1)   Size: 16 MB in 256 Sectors  (MXIC MX25L12805)

In:    serial
Out:   serial
Err:   serial
Start and Send Device Address can't get ACK back
I2C read: I/O error
Net:   Un-Protected 1 sectors
Erasing Flash...
Erasing Bank 0: 100%
Erased 1 sectors
Writing to Flash...
Writing Bank 0: 100%
Protected 1 sectors
No such device: eth#0
No such device: eth#0
PHY_REG0x1f:  8180
Is KSZ8051
no NC-SI channel active or fail to open NC-SI.
eth#0, eth#1
Hit any key to stop autoboot:  0

Run the “tftpboot” command
This will download the all.bin firmware image file from the tftp server to memory

uboot# tftpboot
PHY_REG0x1f:  8180
Is KSZ8051
eth#0 Wait for auto-negotiation complete ... OK   100MB - Full Duplex
Using eth#0 device
TFTP from server; our IP address is
Filename 'all.bin'.
Load address: 0x41400000
Loading:   14 MB
Bytes transferred = 14679680 (dffe80 hex)

Take note of the load address from the previous command.
This is the location of the image in memory

Run the “fwu check <load address>” command

uboot# fwu check 0x41400000
Checking image header CRC ... OK
Checking platform ID ........ OK
Checking kernel image CRC ... OK
Checking rootfs image CRC ... OK
Checking u-boot image CRC ... OK
Skipping u-boot update ...... YES

If this fails the image has not been transferred correctly or you are using the wrong image file.

Run the “fwu update <load address>” command.

uboot# fwu update 0x41400000
Checking image header CRC ... OK
Checking platform ID ........ OK
Checking kernel image CRC ... OK
Checking rootfs image CRC ... OK
Checking u-boot image CRC ... OK
Skipping u-boot update ...... YES
Copying kernel image ........ Un-Protected 26 sectors

Erasing Bank 0: 100%
Erased 26 sectors

Writing Bank 0: 100%
Protected 26 sectors
Copying rootfs .............. Un-Protected 196 sectors

If everything completes OK then the firmware has been installed.

Run the “reset” command and you should see the BMC start up normally and the board should be back to normal.


Dude…thank you for this excellent resource and taking the time to write down here. So important for people to do when theyve had a breakthrough or success. I had the same thing happen on the same board and have been desperately looking for some guidance. Im in a bit over my head at this point but Im fucking determined. My board starts, fans start, no beeps, no video. Worked just before I attempted updating the bios. It looked all good, even said it was all good and I could reboot. Nothing ever since. This board has removable chips and Ive been tempted to have one of those services claiming they can write any chip to get me a fresh one.
With that said, this is fantastic information. My question to you right now is what chip is the BMC chip? There are actually two solderless socketed chips on this board, one 8 pin and one 16pin. I believe the 8pin is the BIOS and the 16pin is an LSI chip? I am totally confused at this point and need someone to give me a little guidance or someone who knows more than I do (not hard) to tell me that its over and to move on. But I really dont think this board is there quite yet and can be resurected.
Any help or words of wisdom is appreciated.

Thank you for this. This might help me fix my BCM that will no longer pull dhcp after updating the firmware on it. Just need to get the cable and I can try this out. Thank you

Tried and not working for me - connected UART to USB cable and opened putty serial connection, powered on board and nothing - nothing happens on the putty screen at all.

Hi,first sorry for my English but it is not my native language.
I got a gigabyte server board MD60-SC0 who had BMC failure at boot time and no access to bios.
bmc faillure happened after a usbdos method updating BMC.
Averythings success during the updating process but after reboot, the BMC initialize boot sequence faill.
I think my mistake was to chose 256M option when asked to me to choose 128M or 256M.

I ordered null modem usb/serial (com) cable to follow this auto cause my PMBus connector is not exactly the same as you, mine is
Pin No. Definition



3 PMBus Alert


5 3.3V Sense

So first I will try by native serial console port if it work.
Have you any idea about witch hardware cable I have to order to connecte usb (putty) to SMBus connector 5pin.
Many thanks for your help.

Sorry to bring this from the dead but do any of you know if this would work to flash the BIOS?

so i ordered some converter signal like uart to i2c , my pmbus seem to be i2c protocol so, wait and see.
Perhaps i will find a solution to flash bios with this methode but first i have to fix my bmc cause it is the first process lanched on boot.
If i succed to fix bmc, maybe it possible to flash bios via web gui bmc interrace after that

I on my MD60-SC0 gigabyte motherboard, I finally find JTAG uart pin, and get communication with putty BUT, the screen is unreadable like wrong ascii format texte or caracter.

So, research on web give me a clue about the issue of putty communication. Perhaps my home made UART /RS232 /USB cable is poor quality and cause bad transmission that make bad retransciption in putty.
Wait and see when I will receive my 5 different adaptor UART ttl usb and convertor I2C, SPI, UART etc.

@MAGADE This is an English forum, please post in English.

oh, sorry, english is not my native language so i had write in french naturally, sorry for this 3 poste in french. I will repost it in english asap

Ok, so i received my new converter signal, it work well, for now, i get access to u-boot properly without “hieroglyphe” (i mean humain language ).

If like me in putty you have unredable caractere when connected to motherboard, it probably due to wrong jtag cable, converter signal module, voltage used or wiring.

I will put some picture asap.

If you don’t interrupt boot process of u-boot, you will get perhaps some error message that will give to you somme clue on what matter exactly and if you are locky let you know how to fix.

So about status fix gigabyte MD60-SXC0 motherboard with corrupt BMC:

-i’m currently abble to acces motherboard microprogram in console putty using good signal converter.

Thank you for sharing

don’t forget to invert tx rx bitwin out signal converter and in jtag pin of motherboard

ok need help, update firmware ok, it update bank0 properly BUT on boot, it is bank1 is charged so bug cause i appolegy that it is bank 1 corrupt, so
how can i switch boot bank order or how can force update firmware to bank1?

it is not perfect but now get a normal screen, fonctional bmc and bios. some screen bug and for the moment trying to get bmc webgui acces to flash bios properly and perhaps bmc again with automatic solution of web gui