Unraid not connecting to network

2 weeks ago i setup a nas server(like the 5.0). it setup fine with unraid, i got the trial key and everything. but i had a power outage. now it wont connect to the internet. the ip address starts with 169. my home network is I didnt haev any data on the drives yet i was waiting for the HP Prodesk 400 to come in. I tried reinstalling unraid to the flash, but still no dice. any ideas? thanks

A 169 IP address is normally self-assigned. Are you getting any lights on the NIC of the server?

Yeah green lights

What motherboard? What port are you connecting it to?

Asus z97-a, it just connected to the Ethernet port on the motherboard

Boot Unraid in GUI mode, then show us a screenshot of the network settings page.

I’ve had it up the weekend here is the network settings

Disable bonding on the interface. Try a different cable.

Ive tried a couple different cables, the one that’s on there now was one a different computer before and it worked on the other computer. but when i changed the bonding, i got interface Ethernet Port 0 is down. check cable. the port was working before because i had it connected to the internet. after disabling the bonding do i want the enabled bridging on?

Bridging is necessary for docker and VMs, so it’s OK to leave it on.

Looks like your router isn’t assigning an IP address to your server, for whatever reason. A 169 address means it’s self-assigned.

so are there settings in the router i can change?? i haven never messed with it since Comcast installed it

i unplugged my unraid machine from my network and hooked up my ubuntu machine with the same cables and it connects fine, i can get to the internet.

I had the same problem. If I recall correctly, I manually assigned an IP address that I knew wasn’t in use (for example That allowed unraid to connect as before. Then I changed IPv4 address assignment back to automatic.

Edit: Changed DHCP to IPv4 address assignment

did you change it in settings, then just hit apply? did you change it them reboot?

If I recall correctly…

  1. Boot unraid in GUI mode
  2. Manually assign an IP address (10.0.0.x)
  3. Reboot
  4. View IP address
  5. If 10.0.0.x, try setting back to automatic
  6. Reboot again and view IP address

For me, this caused it to begin picking up the correct address of 10.0.0.x. Best of luck.

Wonder why people are suggesting assigning an IP and if it works go back to auto. Your unRaid server should be given a static IP and it should stay that way. It is a server, you don’t want the IP changing. I got rid of my provider router and put my own in. Did you get this resolved yet? Since it connected to your Linux server fine with the same cable, you know the cable and server are fine and it is a problem with your router.

Better to leave all your devices on DHCP and set static reservations in your router for whatever devices need fixed IPs. Much easier to configure all the statics from a single interface, and when you configure a new device you don’t need to remember which IPs you’ve already assigned. Also, if you ever replace your router and the new one has a different default local subnet, your devices will pick up IPs in the new subnet and still be accessible.


If you haven’t gotten anything else to work yet, shut down unraid and try this. Mount the flash drive in your desktop system, browse to the config folder and rename network.cfg to network.cfg.old. If your folder contains a file network-rules.cfg, rename it to network-rules.cfg.old as well. Then plug the drive back into your server and boot again.

I did not see where anyone mentioned a static reservation. I keep a spread sheet with my addresses and have them all in a range below the DHCP assigned ones. I have had problems in the past when swapping out a nic or MB and the interface changed MAC addresses so the reservations got screwed up in the router as it thought it was a different device.

That sounds like extra steps. Static reservations are the way to go for home use.