Two Supermicro boards. Two CPUs. Two PSU. Same issue. No Boot

I’m out of ideas. Trying to build a new server to replace an old one using this site as a guide. Here’s what I’m using initially:

Motherboard: Supermicro uATX X9SCM-F
CPU: Intel Xeon E3-1270V2 Quad Core 3.5GHz 8MB
Memory: Hynix 4x 8GB 32GB DDR3 ECC UDIMM RAM PC3-12800E 1600 MHz P
SU- 750 n1 EVGA

This setup didn’t work at all. The board power light came on but fans simply click on then click off, then click on and click off. No boot.

Breadboarded and reduced the whole setup to 1 ram and no change. Reset CMOS no change by pulling the battery and no change.

Replaced the entire Motherboard with a super micro: MBD-X9SCI-LN4F-B (used from a different vendor). Replaced the CPU with another Intel Xeon E3 (different vendor).

Here’s where things get interesting. This setup worked, but the motherboard kept saying I needed an admin password to enter the BIOS. Frustrating because the default admin password didn’t work. So I reset the CMOS and now the same exact thing is happening. I reduced to just one ram and no change. Now no matter what configuration I can’t get anything. I think it might be a PSU issue? So I replace the PSU with a EVGA 650W D3. No. Friggin. Change.

Here’s some more pics with heatsink attached:

What could possibly be wrong? Is it the power in my house that’s the issue? I’m running other computers with no issue. I don’t have any experience with super micro motherboards. Is there a trick or a step I’m missing? How could two boards have the same issue? I must be making a mistake but I’m not sure what.

Here’s a video of the motherboard breadboarded and plugged into just the PSU. Ignore the glob of thermal paste. I had just removed the CPU heat sink because I was worried that might be shorting something. You can see there’s a green light on the board. As soon as push power the PSU just clicks on and off. This happens with all my configurations. I’ve tried each of the 4 sticks of ram. Each CPU. Each PSU. Each MB. I’m not sure what to do next except return everything (which I don’t want to do) and try with a different motherboard and chipset.

Please upload pictures directly to the forum, do not rehost them.

Can I ask how you are turning the board on?

If you are getting a password prompt before getting into the BIOS, then the seller is not doing their job. I’d send the board back, as there should be no password required unless you specifically set it.

PSU switch on then power switch in the front panel which seems to cause the PSU and fans to start but no boot. I agree about the password, but why would both MBs from different sellers have the same issue? I feel like the problem must be something im doing.

The motherboards probably came from the same place. There may be a physical jumper on the board that will completely wipe the BIOS back to default. I’d recommend you start digging through the manual.

Alright, thanks. I’ve reset the jumpers. Switched motherboards, ram, etc, again. Still the same exact issue. Switch things on. Power spins up. Power spins down. It must be a short on both boards somewhere. I’ll return them and buy a new motherboard. These were both from very highlight-rated Ebay sellers. So I still think it’s something I’m doing, but I read through the manual many times. I’ve set up numerous builds before without issue so I’m just perplexed.