Supermicro X9DRH-iF - cannot launch Java KVM over IP applet

Hello everybody!

I recently purchased another SuperMicro motherboard, model X9DRH-iF.

Unfortunately, when I updated it to the latest BIOS & BMC the iKVM feature stopped working.

What happens is the launch.jnlp applet gets downloaded (accessing IPMI via https://), but upon starting it I’m faced with such error message:


Now some detailes:

  • X9DRH-iF:
    ** BMC version: 03.62
    ** BIOS version: 3.3
    ** CPUs: Intel E5-2609l
    ** 2x16GB DDR3 ECC
    ** 2x8GB DDR3 ECC

KVM clients:

  • Windows 10 20H2 19042.685
  • ArchLinux w/ Firefox
  • both running Java 8u271

Troubleshooting steps I took so far:

  • used solarkennedy/ipmi-kvm-docker to launch the KVM console
  • reflashing BMC (to the same FW version)
  • using different PC (both Windows 10 and Linux )
  • using older Java version
  • clearing BMC settings ( = reset to factory defaults )
  • cleared java cache files
  • set java to direct connect instead of using browser settings
  • updated time/date settings in BMC/BIOS ( they seem to be using the same HW clock ? )
  • changed java security settings to allow encrypting the connections with SSL2.0 (as well as I tested all TLS versions in java configuration)
  • tried launching remote KVM via IPMIviewer from SuperMicro - it didn’t work neither!
  • preview image is working fine on the main page of IPMI
  • I do have tried turning it off and on again

I checked if KVM from other board would work - and I successfully launch KVM console on X9SCM-F board running BMC firmware version 03.52.

What can I do to get this feature back?
Have you ever faced similar issue?
Can I downgrade the BMC firmware? Where can I get older version from? Didn’t find it anywhere ;/


LOL it works on MacOS. Need to determine Java version over there. What else could be different?

Managed to launch the console via Turbo following this guide, however I am still unable to install java properly and launch it natively…

I took my chances and successfully downgraded BMC itself without downgrading from currently newest BIOS. Works like a charm now!

BMC 3.55 for X9DRH-iF

Help resource

Related reddit thread

Thank you everyone!