[solved] Ipmitool says "Unable to establish IPMI v1.5 / RMCP session" with GA7-PESH2

Trying to connect to the Gigabyte GA7-PESH2 via ipmitool and recieve the following error:

[alex@randy ~]$ ipmitool -H -U admin -P 123! -I lanplus chassis power status
Error: Unable to establish IPMI v2 / RMCP+ session
[alex@randy ~]$ ipmitool -H -U admin -P 123!  chassis power status
Activate Session command failed
Error: Unable to establish LAN session
Error: Unable to establish IPMI v1.5 / RMCP session

I can load the IPMI web interface on that IP from this box so I am plugged into the correct port.

I used nmap to check the port is open, it is.

sudo nmap -p 623 -sU -P0
Host discovery disabled (-Pn). All addresses will be marked 'up' and scan times will be slower.
Starting Nmap 7.91 ( https://nmap.org ) at 2021-04-11 21:06 EDT
Nmap scan report for awesomo-ipmi.ktz.lan (
Host is up (0.00034s latency).

623/udp open  asf-rmcp
MAC Address: 00:C0:A8:12:34:56 (GVC)

Nmap done: 1 IP address (1 host up) scanned in 0.26 seconds

I also tried the password in quotes or via stdin by omitting it. I have also reset the password and power cycled the BMC.

I don’t know anything about IPMI but from looking at both your post I think that you entered the wrong port number into the command in the first post.

In the second post you are scanning for port 623 but in the first post you are trying to connect to port 123.

I hope that helps.

The -P flag in ipmitool is password.

Don’t bother with old IPMI for now, keep using lanplus. Add -v for verbosity to get useful output (up to 3), as right now the output is mostly worthless.

@ron.goree -P is not port, it’s password which I obfuscated because #internet

@Riggi I couldn’t quite find a clear answer as to which ‘version’ of IPMI this motherboard supported. Does it work like that? V1 or V2?

As I was gathering more logs it is now working. FML. I guess some combo of everything I tried did the trick.

ipmitool -I lanplus -H -U admin -P 123  chassis power status 
Chassis Power is on
1 Like