SAS drives disappearing with error

I’ve had a Gigabyte GA-7TESM and recently purchased (4) 8TB disks as offered on 5/9 from Rhinotech. These are attached via a SAS cable to the motherboard port. (The (4) other SATA drives to the motherboard’s SAS port are working normally.)
The problem is when I add them to the array, they disappear. There is an error message in dmesg for each attempt:

Help. Where do I start?

It looks like the drive that is SDI in the photo is bad. Figure out which drive that is using the serial number and unplug it completely.

Thanks for the idea. These were Seagate refurbed in static bags, so maybe bad. but…
I eBay purchased a 9207-8i SAS card, hoping that it will work under that. The 2008 SAS controller built in doesn’t do 4KN drives.
I’ll let you know

Well, the 9207-8i arrived, and moved the new data cable and these 4 disks over to it. Same error on all four drives, like before.
The disks starting with 3500 are the 4 new disks ( sdb, sdc, sdd, sde ).
03:00.0 SAS 9207 (LSI 2308 chipset) is PCIe card (new)
05:00.0 SAS 2008 is built into the motherboard
How do I attach a diagnostic file? (Forum won’t allow .ZIP)
What am I missing?

Is your 9207 on P20 or P21 firmware?

The Avago Technologies Config Utility shows:
LSI2008-IT -
SAS9207-8i -
Or is there something else I’m looking for? I found 9702-8i package P20 on the Broadcom site.

/bin# sas2flash -list
LSI Corporation SAS2 Flash Utility
Version (2014.09.18)
Copyright (c) 2008-2014 LSI Corporation. All rights reserved

    Adapter Selected is a LSI SAS: SAS2308_2(D1) 

    Controller Number              : 0
    Controller                     : SAS2308_2(D1) 
    PCI Address                    : 00:03:00:00
    SAS Address                    : 500605b-0-074b-7f40
    NVDATA Version (Default)       :
    NVDATA Version (Persistent)    :
    Firmware Product ID            : 0x2214 (IT)
    Firmware Version               :
    NVDATA Vendor                  : LSI
    NVDATA Product ID              : SAS9207-8i
    BIOS Version                   :
    UEFI BSD Version               :
    FCODE Version                  : N/A
    Board Name                     : SAS9207-8i
    Board Assembly                 : N/A
    Board Tracer Number            : N/A

    Finished Processing Commands Successfully.
    Exiting SAS2Flash.


Well, I moved the SAS card and the 4 SAS drives to my desktop as a test. They all show up fine. Formatted, copied 1TB over at expected speeds. They work fine.
I moved them back, and nothing. I tried with the onboard SAS controller disabled, but still didn’t work.
Any thoughts before I contact unRAID support?