Persistent disk IO errors on new build

hey all! i have a build i’m currently working on, a small NAS, but i’ve been running into some very strange issues with it.

initially i built out the system with 5x4TB IBM SAS SEDs since i got them cheap, and despite passing SMART tests and seatools self-checks i was unable to partition them or add them to a zpool- any attempts to do so (or really access the disks at all) would result in a number of IO errors in dmesg. a couple of the errors i was able to observe:

async page read
sense key : data protect [current] (followed by “no access rights”)

i tried swapped the cabling and the HBA itself, but kept seeing the same errors. eventually i swapped the disks with some known good 4TB WD reds that have been running happily for just under a year in another box. this worked well for a while, until suddenly the disks started exhibiting similar issues as the SEDs.

at this point i’m more or less out of ideas, firmware on the drives and HBA is up to date, the BIOS is up to date, i’m on a recent kernel with all the drivers i’d need, but i can’t seem to make this work. i’m not suspecting backplane damage right now because the WD reds didn’t immediately display the same issues, but that just leaves me with nothing to go on. :slight_smile:

appreciate any insight you guys could provide!

SEDs have a mode referred to as auto-lock mode. In auto-lock mode, the disk uses an authentication encryption key (AEK) to protect its DEK. When a disk is powered off, the disks are automatically locked. When the disk is powered on, the SED requires a valid AEK to read the DEK and unlock the disk to proceed with read and write operations. If the SED does not receive a valid authentication key, the data on the disk cannot be read. The auto-lock mode helps to protect the data when disks are accidentally or intentionally removed from the system.

from IBM Documentation

Looks like you bought some cheap/expensive junk drives that are of no use to you.

hm, well that’s definitely no good, but thank you for the insight. since the drives are unusable i should be able to chase down a refund, fingers crossed :slight_smile: