[Official] Aruba S2500 Managed Ethernet Switch (PoE+/10GSFP+)

I downloaded the firmware and 7zip says its password protected. Please advise.

You should read the post you just responded to that contained the download.

I re-read the post and don’t see what I’ missing

1 Like

LMAO I thought of that but honestly I’m cheap and have some silent 120mm fans laying around from a recent computer upgrade. :stuck_out_tongue:

Hi All - I just purchased a new home and am in need of a 40 port POE switch. I don’t need anything fancy in terms of vlans or anything like that, just a switch that has POE that has 48 ports. It seems that this switch fits the bill for being a drop in replacement for my tp-link dumb switch - is that correct? Seems that way, but I don’t want to buy from ebay only to realize I made a mistake.

Thanks

I would probably suggest restore+update first, but then it should happily run as a POE-enabled dumb switch. I’m almost completely certain the default settings has POE enabled.

Thanks - once I get setup and buy this I’ll factory reset + update and will post here if I have any questions.

Just got a ArubaS2500-48P from ebay and I simply cannot connect to the WebGUI through any of the gigabitethernet ports. I have tried:

  • Factory reset and using quick-config via the LCD and via the console CLI
  • Manually assigning an IP address to the default VLAN
  • Flashing between 7.4.0.7 and 7.4.1.8
  • Cursing loudly

I can reach the WebGui fine if I assign an IP address to the management ethernet port in the back (out of band), but I cannot ping, get a DHCP address from or otherwise see the switch on the main GBE ports. (Layer two is working fine between hosts on the front…)

I do have access to the GUI (mgmt port) and the console (USB) so that is good, but I just can’t get the the switch to respond to pings or serve DHCP, using factory reset / quick-setup or with config settings I am aware of.

Do I have a bad switch somehow? Any advice or help appreciated.

Here is the current config if that helps.

Don’t use the quick-config. Just factory reset, then connect to your network. It will receive a dhcp address. Log into that address and config it.

My question is can anyone tell me how to configure this switch with Chrome?
Whenever I try the “entry” field doesn’t show in chrome unless I click and not “unclick”. If I use IE tab the entry box stays open but I’d rather use chrome alone.
Is anyone using Chrome to configure these?

I just found a “workaround” if anyone else needs it.

Click and hold in an entry field, the box will appear. While still holding the left mouse button, click the right mouse button. The box will now stay open.
Type your entry, then tab to the next field if any, do not click in the next field, it’ll close the entry box. When all is filled in, click on OK.

Had to find this the hard way, but here’s where you can get the latest Aruba OS for the switch:

Latest version is ArubaOS_MAS_7.4.1.12_72393, but looks like they also released a LTS update of ArubaOS_MAS_7.4.0.7_80725 in 2021. The links for the changelogs don’t work for me, so I’m not sure what the difference is.

Also for anybody wanting to do the Noctua mod, get 8 x M3x25mm flat-head machine screws and matching nuts. They will sit flat in the original fan screw holes, and you won’t have to drill anything out.

I have been trying to manage my ArubaS2500-24P its on FW 7.4.1.12 and its just become very unstable as of late. I am getting kicked off when I am using both SSH or HTTPS with IE. (I have not tried the console port yet) but has any one seen a issue as of late with there Aruba switches. What FW are people running.

I’m on ArubaOS_MAS_7.4.0.7_80725. Nothing to report as of yet.

That’s the release that came out last year (Jul 14, 2021) but what I find funny is that release has a lower build number over the version I am on.

I think it must be an LTS version.

So my Aruba came with only 1 rack ear, so I bought these and modified them:

There’s some bumps on the inside that you have to grind off, and then take an 11/64" drill bit and enlarge the 4 openings nearest the screw holes for the switch body.

Original Ear:

Hacked Ear:

The switch will sit forward about 3/8" from the stock ears, but you can at least find these.

Here’s the release notes for 7.4.0.7: https://support.hpe.com/hpesc/public/docDisplay?docId=a00116700en_us

And the notes for 7.4.1.12 :https://support.hpe.com/hpesc/public/docDisplay?docId=a00090821en_us

You can find the differences between 7.4.0.x and 7.4.1.x by searching for “Starting from ArubaOS 7.4.1” in the 7.4.1.12 release notes.

Fwiw this AOC works great between my s2500-24 and my Mikrotik CRS326.

10Gtek
AOC-S1S1-005-CSC-X
Compatible for Cisco SFP-10G-AOC5M