Need some help on a few issues

I’m not massively technical and this has plagued me in getting advice before, so please either be patient with me or if I’m too stupid for you, please just don’t bother replying. I’ve tried the Unraid forums and reddit, as well as help from a friend that I’d rather not bother anymore with my silly issues!

As an intro, I researched building my own NAS, graduating from a Seagate 3TB Personal Cloud to a Raspberry Pi with attached disks, before researching and building my own little server. I used pcpartpicker and built a computer for the first time. The case was too loud so I changed it, and things were okay. I’d link to a PCPP completed build but i get an unknown error on it for some reason. I’ve ended up with a 36TB array (12TB parity) that I love.

Parts list
[hide]MSI B450M Mortar Titanium Arctic
AMD Ryzen 5 1600
2x8GB Corsair Vengeance White RAM (going for the all-white theme)
I have a stupid little GPU that I can’t actually tell if I ever needed, though I could never get the GUI to show before I bought it, so.
2x WD 10TB
2x WD Red 8TB
500GB m.2
LSI SAS board

Now, I’ve always had little snags which have resulted in little odds and ends being unfinished and I wanted to branch out and find somewhere I can try to either get more help or advice. I essentially run Plex and qBittorrent. I wanted initially to run a lot of things such as Calibre/Ubooquity/COPS comic reading app, Jdownloader/youtube-dl subscriptions etc, a Pihole if possible, and a VPN.

[hide]The latest issue I’ve been dealing with is the VPN, which, I think, links to a current new qbittorrent issue. I signed up for PIA so I could route qbt through it. I’d been running linuxserver’s container, but downloaded the binhex-vpn container for it. I followed spaceinvaderone’s tutorial. As it stands currently, I have the binhex container which produces an “Unauthorized” page when I try to load the WebUI. Perhaps it attains to sharing the same ports as the OG container, so I changed them. No avail. As spaceinvader doesn’t seem to troubleshoot, I’m at a loss as how to proceed.
Simultaneously, or coincidentally (I’m not sure), the OG qbittorrent now does not add any new torrents. This has happened since creating the new binhex container. I stopped the binhex and restarted but this hasn’t corrected it.
I downloaded the PIA chrome extension but haven’t installed the VPN on my laptop as I’m unsure if I have to? I guess I do use firefox, too.
I had initially wanted to be able to access the entire server via a VPN if necessary, ie to pause downloads if someone was home, but as it stands, that won’t be possible.

My last venture trying to set up a VPN to cover the entire server has potentially left my wifi insecure. I was following a spaceinvaderone tutorial into setting up a VPN, but when he goes into his router settings, mine, Sky, didn’t have some settings regarding port forwarding that his did, and so it was half done. I wasn’t sure how to proceed and months, maybe a year later, I’ve changed nothing, and so have potentially left my internet vulnerable.

[hide]Plex is working okay these days, once I changed the settings to always transcode to a low quality 1080p. Before then, the buffering or transcoding would just crash the app on my TV. Things seemed to work okay on laptop, but perhaps that was transcoding automatically. I’d like to watch in higher quality but I’m not sure whether the problem is CPU, GPU, RAM, Plex, TV, connection or what. It was infuriating as we’d sit down to watch a movie and it would stop 5 minutes in and crash the whole app. At times, Plex was totally unusable at all, it simply wouldn’t load. Really I’d just like to watch things at the quality I download them at, which is primarily 1080p Remuxes.

[hide]youtube-dl. I want to “back-up” hate5six’s videos and DaiTanFilms. These are live punk gigs. youtube-dl never worked for me, for seemingly no reason, so I tried Jdownloader2 which downloaded hundreds of GBs for a while until it stopped. I’m now onto using youtube-dl-material which I think works. There are often new videos in the folders, though seems some get missed, but I don’t want to mess it up. However, the Plex folders are pointed at the folder I created with Jdownloader2 which is right next to the one youtube-dl-material created. Can i just move the youtube-dl-material videos over or will they re-download? I don’t even know if it’s downloaded ones I previously grabbed with JD or maybe only new ones. Don’t know if there’s a gap in videos. We’re talking hundreds of videos though, so.

I’ve been using youtube-dl-server to create a little folder of Official Music Videos, which I enjoy on shuffle recreating watching Kerrang/Scuzz/MTV when I was younger. this works quite well with a basic GUI where I choose “Best Video” and it downloads and then I move it to my /officialmusicvideos folder. However, it just stops. There is nothing I can do to make it work again. The container itself works, it just ignores my input. I’m about 600+ videos in, all manually entered, it’s as if it exhausted itself but… I want to keep using these youtube containers but they all just break and I don’t know how to fix them.

All of these issues, while may seem small to you, have stopped me from proceeding with other ideas and stuff in the past, so while I had bigger ideas for the server and storage, I’ve just resorted to using Plex and torrents, sometimes using FileZilla to download from my seedbox (now that qbt won’t add). As much as I’d like help to fix these things, I’d also like to try to learn and add more suggestions to my box.

I have about 5TB left and need to grab another HDD but unsure these days which to grab. Perhaps stay with the WD theme, and perhaps a 14TB or even 18TB and replace the parity whilst aiming for longevity, as the others can be upgraded up to that, as you all know. However, I get nervous due to the 3.3V pin issue and I don’t like the fact that my HDDs have a bit of tape stuck in there forever.

I’m sorry this turned out more like a rant, but I’m incredibly grateful if you read even one section and especially if you can help me, or fine-tune my system. I feel like I’m missing out on the experience (and speeds, maybe) that others enjoy and just want to join in the fun and show my partner all the cool things we can do/watch/listen to haha.

Thanks very much

What TV are you using for Plex? Maybe try transcoding one of your movies to be able to direct play on your TVs app and see if that helps. If it doesn’t, it may be be a client-side issue with the buffer: either it is too small or it isn’t being fully utilized.

@sushinori The hide tags do not work with our markdown.