NAS Killer v4.0 - DQ77KB not Posting

Hello - this is my first time building a server. I followed the parts list for the six bay mini itx build. Currently I am unable to pull up the post screen on my monitor.

Current behavior:

  • When I power on the fan will run for about 3 seconds stop (it looks like it mobo turns off) then start running again
  • USB Keyboard is not being detected
  • Monitor is showing no signal source
  • Motherboard is lit up and powering anything that is attached to it.


  • Tried booting with just the heatsink, cpu, and the power switch connected and behavior is the same.
  • Checked cpu and socket for any damage but everything looks fine.

Any help would be greatly appreciated

Have you tried alternating ram in different slots? Also try each individually in different slots

make sure the board is not grounding out…even remove board from the case if it’s in one.

might need to list your processor as well…maybe you got one that needed a bios update before using.

Thanks for the quick response.

I have alternated the ram. and the board is currently being run on my desk out of the case.

Processor: [Intel E3-1260L 2.40Ghz Quad-Core ]
RAM: [Kingston 8GB (1 x 8GB) SO-DIMM DDR3 1600 (PC3 12800)

I did see on one of the intel websites “DDR3 1600 MHz SO-DIMMs are only supported by 3rd generation Intel Core processor family processors”. Would this be why it is not posting? I ordered some 1066 MHZ Ram which should be coming tomorrow.

add cheap PCIe GPU?

I really don’t think memory speed is the issue…it would probably just work at a lower speed.

Hey Sean - do you think that would help considering usb drives are not working currently either.

Ok guess it doesn’t hurt to try. I will look into the bios update and try to perform tonight.

unless you get it to POST you won’t get that far.

It’s hard to speculate any futher beyond trying different ram, maybe a different processor. That’s the issue with parts you’ve probably never seen work. You have no idea what’s actually good.

Another shot in the dark may be to clear the CMOS. There should be jumper on it somewhere.

I assume that it gets it’s power from a DC power brick? Do we know it’s the correct one for it?

Try putting the BIOS setup jumper (page 70 in the manual into Configure mode.

I had at least one DQ77KB come with the display defaulting to the LVDS connector, so I got no output from the HDMI port.