NAS Killer 4.0 troubleshooting - power issues

So I went with the featured build, and I was able to POST the first time. I restarted it, and I was stuck in a boot loop. I tried clearing the CMOS, but now it immediately shuts down after powering on (CPU and PSU fans spin for about a second). I tried cutting it down to just the CPU and a single RAM stick, but I get the same result. Anyone got any ideas?

Have you checked the jumpers? I’m assuming you have the Acer board, so you can find the default positions on page 8 of the manual:

I’d also check to make sure your standoffs are all fine, though I think if there was something wrong with the standoffs it wouldn’t spin up at all. Are you getting any beep codes?

1 Like

Can’t seem to open the link, but I do have the Acer board. I guessed the power pins (couldn’t find the manual at the time), and it worked at first. I have it on an insulated surface at the moment, and I’m not getting any beep codes (it sounds like it’s getting cut off and shuts down immediately).

Sorry about that, here it is:

To me it sounds like a jumper issue, but if that still doesn’t fix it, I’ve found that when it boots up and powers down again the RAM is often the issue. Maybe try switching out the stick you have in, or if you have any spare memory that would be compatible swap it in.

1 Like

Hmm, so I don’t see anything that seems wrong with the jumpers. Everything is set to default, and the connections are secure. Is there something specific I should do or look for there? I did try multiple RAM sticks, and the PSU is from a working PC, but I’ve still got nothing. Fans still spin for a second, and it shuts down right after.

Could just be a dead board. Could you upload some picutres of your test bench setup?