LSI 9300-16i can't see drives

Hey All,

I recently broke out a 9300-16i I bought somewhere to upgrade my server, but I cannot get it to see my drives at all. After fighting with efi shell to get my flash drive mounted, I was able to flash it with the latest ROMs from the LSI support site (mpt3x64.rom, mptsas3.rom), and I flashed the firmware with the IT version that was released for the TrueNAS crowd.

I tried over and over thinking I misflashed it somehow, tried erasing it first with -e 7 and learned how to manually update the SAS address because of that.
I got it to a good point but it still sees nothing attached, I’ve tried a second cable as well but no dice.

I also tried an ASR-8405 and that doesn’t see any drives either.

If I put any of my LSI 92xx cards in, they all see the drives. I have verified that it’s not power related though by trying it with a 750W Seasonic.

The breakout cable I’m using is this one from
CableDeconn: SFF-8643 Internal Mini SAS HD to (4) 29pin SFF-8482 connectors with SAS 15pin Power Port 12GB/S Cable (1M)

On the other end are two HGST He8 Ultrastar 8TB drives, and 2 Samsung Pm1633a drives, all of them SAS3 / 12gbps.

I have no idea what to try next, any ideas? TIA

Have you 3.3v modded the drives?

@JDM_WAAAT I haven’t modded those drives. The 4 drives on that cable are split between 2 HGST He8 Ultrastar 8TB SAS3 drives, and 2 Samsung Pm1633a SAS3 drives. They worked with my SAS2 HBA/cable. I just double-checked the power pass through on the SAS2 / SAS3 cables and they’re both just 15 pin power passthroughs, so the power being supplied between the working SAS2 config and the non-working SAS3 config is the same.

It’s weird that neither SAS3 HBA works though, I’m stumped on that.

Is there anything I should try adjusting in the BIOS? I’m using an X10SLH-F motherboard with optimized settings minus the boot order/selection.

You should try the 3.3v mod first. What’s powering the drives? Backplane, cable, or something else?

I’ll be damned, that fixed it. I removed the 3.3V wire from the Sata power splitter cable and they spun up. For some reason with my SAS2 HBA/breakout cable it didn’t need that mod.

I’m using one of these to connect to the drives, and then powering that with a Sata Power splitter cable: SFF-8643 Internal Mini SAS HD to (4) 29pin SFF-8482 connectors with SAS 15pin Power Port 12GB/S Cable (1M)
Cable Matters 2-Pack 15 Pin SATA to 4 SATA Power Splitter Cable - 18 Inches

yep, several SAS3 12gbps drives require you do disable 3.3v power. my HGST and Samsungs do. but i dont’ know of any SAS2 6gbps drives that require it disabled.

maybe the old breakout cable was missing a 3.3v power wire entirely?