I7-11700 QSV Build Problem

Hello all – I just recently put together a QSV HW transcoder using an i7-11700 (UHD750) on an ASUS B560M-A mobo, 32GB ram, and 512GB NVME drive with Ubuntu 20.04 LTS and Plex. I realize this is very much overkill, but I have some other plans for this build once I can wrap my head around the QSV issue. Got everything installed and, while the computer runs fantastically, I can’t seem to get the hardware transcoding working. I upgraded the kernel to 5.12 and 5.13 and still can’t seem to get HW transcoding working properly. I’m a newbie with Linux, so there’s a chance I’ve gunked something up.

I don’t even know where to start really. The tips I’ve found from various forums haven’t seemed to work. Does anyone have recommendations?

What all have you done? And how are you confirming that it is not working?

These are a few of the things I tried – having trouble remembering them all.

  1. Deleted the HD driver from /dev/dri leaving only the i915 driver
  2. Added “options i915 force_probe=4c8a” to /etc/modprobe.d/i915.conf
  3. Added "GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash i915.force_probe=4c8a $vt_handoff” to /etc/default/grub (then update-grub)

lshw -c video reports the following:

       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       logical name: /dev/fb0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list fb
       configuration: depth=32 driver=i915 latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
       resources: iomemory:600-5ff iomemory:400-3ff irq:146 memory:6000000000-6000ffffff memory:4000000000-400fffffff ioport:4000(size=64) memory:c0000-dffff

When forcing a video to transcode in plex, I’m not getting the (hw) after the transcode message. Both hardware acceleration options are checked in Plex settings.

Any thoughts?

How are you forcing a transcode?

By changing the quality from Original/Maximum 1080p/30mbps to something smaller like 720p/4mbps or lower


Do you have an active Plex Pass subscription?

Yessir I do - tried signing out of everything and back in as well.

Looking for any other ideas to try or guides to read. TIA

You probably already figured it out, but I think the 11th gen cpus need the ubuntu 21 core. I think there are ways to upgrade 20 enough to get it working, but the easy fix is to install ubuntu 21. I havent built one yet just read the threads over at plex forums.

Thanks Raize – In the end, I bit the bullet and just upgraded everything to 21.04 and it ran perfectly. Prior to that though, I tried upgrading 20.04 to different kernels 5.8, 5.10, 5.11, etc and things got wonky.

1 Like

check the motherboard bios CPU support. Sometimes motherboards require the latest bios to support the newer CPUs.