I need some help with NAS killer 4.0 build

I believe I followed the guide properly, but I can’t get my build to POST.

Motherboard: Supermicro X9SCM-F
RAM: SK Hynix 16GB 2Rx8 PC3-12800E Unbuffered ECC RAM
CPU: Tried E3-1220 V2, but don’t think the BIOS is upgraded to V2, so I now have a Pentium G620
Powersupply: Thermaltake 430W

The motherboard has 2 short beeps on startup, which I believe is normal?
It doesn’t do anything, though. It just goes to a red screen with lines. I can’t access IPMI either.

I’ve tried a new CMOS battery and tried clearing the CMOS.

Does anyone have any ideas what the problem may be?

Just two beeps?
Is there a sort of ‘breathing’ green LED somewhere around the network ports-ish? (signals the IPMI has initialized)
Try just one RAM stick.
And try to find out, maybe checking your router, if the IPMI management is up and running - you’re already plugged into the corresponding ethernet port.

The IPMI heartbeat LED is not on. My router is not showing a DHCP lease for the IPMI.

I’ve tried only one RAM stick, but the fans won’t even turn on. I’ve tried the RAM in all different configurations, but it will only power up if I have 2 sticks in, which is weird. Maybe bad RAM?