Help - Server will not post after moving to case

I am at a loss, and hoping for some insight. I did the bench build, and everything was great.
Moved to the case, and now I cannot get the system to POST. Power is good, LED are on, fans spin, but nothing.
Mobo is a X9DRL-EF (ATX)

I have a feeling the Mobo crapped out when I put it in the case, so now I am looking for a new mobo for my build.
My challenge is I have a Norco case that supports CEB, ATX Micro ATX or Mini-ITX boards.
Any suggestions on a new board that will not break the bank?
I was looking at this motherboard…would this work?

Any other suggestions?

Are there any stray standoffs? Can you share some pictures?

I removed all the stray stand-offs, and made sure only the 8 that were on the board were in place, and were secured before powering on.
@JDM_WAAAT…what would you like to see pictures of? I’ve pulled the mobo back out of the case, and its on my bench now, but still refuses to POST.

I would reseat the ram, maybe pull the cpu and reinstall…sometimes wonky stuff happens. Get the board down the absolute minimal that it can run on and see if it posts. Remove all hard drives. A cable to a hard drive or other component could be the culprit.

Yep, I tried all that…still nothing. That is what leads me to believe the board is dead.
Now I am on the hunt for a dual socket board that will fit in the case I bought…

What about clearing cmos?

It’s pretty unlikely that the board is just dead all of a sudden. Can you share pics of how it’s set up now?

Here are a few images of the setup currently, and a short 45 second video of what happens when it’s powered on.

Tried clearing CMOS and no change in behavior. No beeps, no POST…

Does your cpu fans spin?
try leaving it on and see if it reboots itself over and over it may not be your mobo it could be your psu.
try another psu.
try using one cpu after that

Looked into it a bit more, could you leave it on alittle more, it looks like its going through post very slow, you stopped vid too soon.
your mobo is flashing on the video part of post, look at pins for onboard graphics or try resetting bios with another graphics card in?

A bit more, your mobo manual states you need two sticks of memory loaded for each cpu, it will fail with only one in?
read your manual there is to much in it to state, jumper for onboard manual, memory in the right slots, missing jumpers on mobo on and on i think you missed something simple.