[Guide] NAS Killer 6.0 - DDR4 is finally cheap

Just a heads-up; you don’t exactly get to pick and choose which data is parity protected. Typically the entire array is parity protected or not, and the catch is that the parity drive needs to be at least as large as the largest data drive in the array. In your case that would mean 1 of your 12TB drives would go to parity. That would give you either 18TB (12 + 2 x 3) parity protected, or 30TB (2 x 12 + 2 x 3) unprotected.

You will need an additional drive to accommodate the datasets you described. Optimally you could add 1 more 12TB drive to get you to the full 30TB, but anything 12TB or less would work so long as it gives you sufficient capacity for your data with a little room to grow.

Potentially with just 1 more 3TB drive you could use 3x 3TB drives in a ZFS raid z1 to get you 6TB of protected space and use the 2 x 12TB drive without parity in the main array for the rest of your data, but I would recommend not over-complicating things, especially if you are new to not only Unraid but to Linux and ZFS in general.

To answer all of your questions at once; Given your use case, I wouldn’t really recommend ZFS at all for right now.

ZFS is an absolutely amazing filesystem, it is in a league of its own in terms of performance, features, and data protection. However, unless you are planning on using some of the more advanced features like snapshots or clones, you will probably see little to no benefit for your use-case. It will protect your data from gama-rays from space, but on the flip side it has a rather steep learning curve and offers a million and one ways for users to completely and irrevocably destroy all their data with a just a single miss-typed command.

XFS is probably a better choice. It is stable, offers decent avenues for data recovery, offers decent performance compared to anything but ZFS; it certainly won’t be a bottleneck for you, and most importantly it is easy to use; set it and forget it.

As far as ECC and ZFS; its not exactly a myth. ZFS does most of its work in memory, and a failing RAM stick can and will wipe out all of your data. In real word use though that is pretty rare. Outside of enterprise use cases where every second of downtime matters I don’t think it is strictly necessary. For a home user, so long as you have a good back-up strategy in place it should not be a problem to use ZFS with non-ECC memory.

Thankfully, the seller of the busted X11SCQ board had a replacement that he shipped to me with priority shipping. I got it yesterday and am back up and running! Thank you all for your advice!

I don’t know if I should move this into private messages or something, but I’m having some issues with this motherboard with a very similar setup.

I bought an ASROCK z370/OEM off aliexpress, a 8500T locally and 2x16 Juror (Aliexpress brand) 3600 DDR4 ram sticks.

The motherboard seems to behave normally: if I don’t put the CPU in, the motherboard doesn’t “turn on” when bridging the contacts. If I put a CPU in, it complains about a lack of RAM. If I put one stick of ram in any slot, the motherboard just sits there, doesn’t output video, doesn’t complain about anything.

I tried resetting the CMOS and even used one of my main machine 8GB/4000 DDR4 Ballistix sticks and it behaves the same. The Juror sticks work on a 2600x AMD machine, so I’m a little stumped.

Did you have any unique problems with this motherboard? I can’t find a Manual for it and I don’t know what else to do, other than maybe tracking down another CPU or lower specced RAM. It seems like the motherboard is failing to test the ram or even run it in the 2400/compatibility mode.

Any ideas?

not sure if it will be the same for you but I had this issue not long ago and it turned out my motherboard firmware was way out of date, updating it fixed it

Thanks for all the tips.

Does anybody know of UK sites for refurbished enterprise hard drives? Looking to get a couple of 12tb drives but struggling to find UK supply (or international with OK shipping costs).

I actually have a similar question to the previous post. I live in France and all those cheaper HDD links have outrageous shippings costs to Europe. ($200 for shipping for the Rhino ones for example)

Thanks for the response, very helpful. Can you point me to any resource for how best to set up my storage and shares based on my use case? I have been running the same basic configuration for four years and it works fine but I want to make sure I am fully utilizing the QSV capabilities from my new processor and the speed of the SSD’s. You mention a Ram disk so any resource to help me configure and use that properly would also be appreciated.

I did a little googling and it and it seems that while some folks use a ram disk as a transcode cache most people actually recommend just using a regular SSD the performance should be the same so it might be best not to overcomplicate things and keep your RAM free for other uses.

As a resource for all things Unraid I would recommend you check out Space Invader One on youtube. He has a ton of really well flushed out guides on just about anything you might want to do.

Here is a general guide on setting up shares and utilizing cache pools: https://www.youtube.com/watch?v=ZOzW01lrzpM

Here is his guide on setting up and using tdarr: https://www.youtube.com/watch?v=U6UMjTlwrxs

For utilizing QSV especially if you are planning on transcoding all of your files to H.265 its important to make sure that your iGPU supports encoding / decoding into the formats you are planning on using. Since you are using a 8th / 9th Gen Intel CPU you should be good for most any format you might be using, but in general if you are not sure the Wikipedia article covering Intel Quick Sync has a helpful color coded table that makes it easy to look up what formats any given generation of iGPU supports: https://en.wikipedia.org/wiki/Intel_Quick_Sync_Video

Hope that helps!

Hi - I reached out to Rhino and they were able to get a better deal on shipping. For two drives I paid $60 shipping with DHL to London. It’s not great, but way better than $200 as quoted in Ebay.

Just message them and use the code per above. I couldn’t find a better deal for an exos disk. Still waiting on delivery and will report back re if the drives are OK.

OK. So, ordered the following:

I5 9500t (used)
Supermicro X11SCA-F (used, China)
2x 12tb exos drives (Rhino)
32gb Corsair Vengeance LPX (black Friday)

I plan to use my existing 2x 12tb drives so will 36tb with parity. I will then use my 3tb drive as a hdd cache.

Just need to get an ssd cache drive for docker. Any ideas of a good drive? I’m struggling again to find used drives in the UK.

Im considering the FireCuda 530, 1tb. That seems to have the best endurance of any drive I can find. But this may be overkill as the MB is PCI 3 x4.

Any other suggestions for the X11SCA-F? I think it can take U.2 connector and may be able to take 22110.

Ok great. Thanks for the tip!

I thought about BIOS version, but I don’t have another CPU to test. However, investigating, this motherboard (ASrock Z370/OEM) has a header (BIOS_PH1) for manual flashing of the BIOS (this particular MOBO has a Winbond 25Q128JVSQ BIOS chip) with a BIOS Flasher - which I do have (in my case, the CH341a). I also found a pinout for the header and my particular BIOS flasher, so I’ll post it here because this actually is VERY useful: [CH341a Problem] Which bios_ph1 Cable for ASRock Z270 Pro4? - BIOS Modding Guides and Problems - Win-Raid Forum

Managed to read the BIOS off the board, it was a version from 2019. There’s a version for this particular MOBO from 2023, from the official ASrock website ( https://www.asrock.com/support/index.us.asp?cat=SIBIOS). I thought that would be the ticket. Flashed the new BIOS and still got the same issues.

Motherboard + CPU = complains about lack of RAM.
Motherboard + CPU + RAM = nothing - powers on and stays on, no video output, no keyboard light. I can power off and back on with the button (so the motherboard is not stuck), but nothing else.

I, obviously, tried a single RAM stick on every slot. The RAM is working (tested on my main computer). I tested with a Chinese DDR4 Stick (Juhor 3600 16gb modules, a paired stick I bought for this build) and the RAM from my gaming computer (Crucial 4000 8gb modules). I’m wondering if these RAM sticks are… “too new”? somewhat out of spec so the computer never gets out of memory testing loop? They do have 2400mhz SPD information in them, so I imagined they would work

This is a regular “computer troubleshooting issue”, but the only reason I posted here is because @Jon_Jon has a very similar setup to what I’m trying to make and I was wondering if they had any insight.

Oh well. Guess I need to find a new motherboard, a new CPU and some more RAM modules to test.

Hi guys, thanks for putting this together, awesome write up!

My goal is to: Run a PLEX server that will run as a substitute for Netflix, Hulu, HBO Max, and other streaming services (want a VPN to protect any services this is running); backup @least 3 icloud accounts; backup @least 7 google drive accounts; backup and maintain annual versions of the entirety of Wikipedia’s articles less media; backup ebook library; self served […Much down the line] smart home w/ automation and an LLM built in.

Build/ Questions: I am following the NAS Killer 6.0 sample build ~except I bought the CPU and Motherboard:
CPU: i3 gen 12 i3-12100T 2.20 GHz Alder Lake Alder SRL64 FCLGA1700 $104.22
Motherboard: GIGABYTE Z690 UD AX DDR4 LGA 1700 ATX Intel Motherboard $78

and am considering the Fractal Design R5 over the Cooler Master N400

Other than that am I still good to just buy the sample build components or am I overlooking anything? Thanks in advance!

I received the drives yesterday.

Looks like they were DOA. Shame, as a good deal if they worked.

Is it uncommon to have DOA used drives? They were shipped US to UK.

I got SATA drives. I tested them in an old Intel i3 2nd gen system. Other drives work fine. These just made a buzz / beep sound every 3 seconds and the other span up but sounded very ill.

Didn’t work with USB caddy either.

Question - Should a new 12tb SATA be recognised / spin up when connected to a 10 Yr old Psu / motherboard?

They’d be fine. SATA does not have a limit that 12 TB would be a problem for and power is mostly power, aside from the 3.3v line issue. What OS were you using

Windows 10 for the USB caddy. Unraid for the SATA 6 connection.

I used this RAM for my build if it helps you trouble shoot.

Silicon Power Value Gaming DDR4 RAM 32GB (2x16GB) 3200MHz (PC4 25600) 288-pin CL16 1.35V UDIMM Desktop Memory Module with Heatsink Gr… Amazon.com