[Guide] Move Your Docker Image and Appdata to an Unassigned Drive (DEPRECATED)

Worked great and the 10+ dockers we have running at any given time are much more responsive. Nice to be able to get some use out of this old Samsung SM951 256GB PCIe SSD (AHCI Version) that has been collecting dust since its last use in a Z97 build while being faster than a SATA SSD.

Now that 6.9 is officially released, are there any special steps to take before the upgrade from 6.8.3 and having docker/app data on an unassigned drive or will everything transfer over?

I didn’t run into any issues when I upgraded, but I would recommend making a backup of your 6.8.3 flash drive (the full zip backup where you click on your flash drive in the main tab of the dashboard and click the Flash Backup button) before you upgrade.


On 6.9.1, I created a new cache pool to move my docker and VMs to. Is moving them manually still required? I changed the 'Select Cache Pool" to the new cache pool and tried running the mover with the shares set as ‘prefer’, 'yes, ‘only’ but they don’t get moved from the ‘Cache’ pool to my new ‘vm_docker’ pool. Any advice? I don’t mind moving them manually if it’s just a one time thing since it is already sitting on the other pool. Just don’t want to mess something up if that’s not recommended.

Edit: forgot to mention, the docker and VM are turned off in unraid while I’m doing this (the tabs are not present).

Do not use the “only” option.

This is similar to the cache SSD swap procedure. Turn off docker/VMs, set the appropriate shares to cache=yes, run the mover. When it’s done, set the same shares to cache=prefer:(new cache location) and run the mover again. Once that’s done, your docker containers and VMs will be moved. Then you can turn the services back on.

I was trying to get it to move from one SSD pool to the other without hitting the array since it takes a long time for it to write there. I ended up just manually moving the folders in /mnt/cache to /mnt/vm_docker_pool and set those to Only:vm_docker_pool. I don’t want it to try to write to the array for any reason on these shares.

If we have this set up, how can we “undo” it now that we can use cache pools to store the appdata?