[Guide] Hardware Transcoding: The JDM way! QuickSync and NVENC

Also, now that plex tonemaps hdr-sdr with quick sync, the hp290 is in fact capable of transcoding 4k! But yes, the general recommendation still stands :slight_smile:

I wonder if the new Apple M1 would handle this? It would be nice to make this recommendation obsolete.

The tonemapping on Plex has a long way to go, original SDR content still looks better. Transcoding 4k is still too much of a resource hog and defeats the point of having 4K HDR content in the first place.

2 Likes

I recently came across your page and builds and wish i would have seen it before building my budget NAS/Plex server… Anyways i picked up a combo deal on an Intel 10100k w/ itx motherboard for $129 via microcenter and built my setup around it with 16GB ram and 2 x $15 128GB M.2 for cache in unRaid and 5 x 10tb HHDs. I have been using the plex docker within unRaid utilizing the iGPU without issues and was able to do over 25 streams without issue, but a few days ago something changed and now i cant get hw transcoding to function properly for some reason.
within plex it displays transcode (hw), but im using 100% CPU usage just to stream 2 transcodes now all sudden.
I tried multiple dockers with fresh installs of plex and no change. I am about to give up on the dockers and try VM with ubuntu, but i read within this page because its a VM it would only do halfway hw transcodes???

Hi guys, am currently building a new Plex server and am following this guide. Can I just check is ubuntu still preferred to Windows 10? I only ask as I am a linux n00b. Would there be a big performance difference?

Thank you!

Yes, Ubuntu is definitely still preferred. The Plex server works much better in linux than in Windows. You don’t need to be a linux guru to install the Plex server, just follow the guide above.

1 Like

Thank you for getting back to me, good to know. TBH, it wasn’t so much the installing but more troubleshooting should something go wrong. Learning curve I suppose :wink:

I had to update 2 new packages in ubuntu for the new PLEX tone mapping to work with intel quick sync. But I can confirm there is a big improvement over the previously washed out colors. Still, no reason to do it, just for information.

One question. I have an Intel Core i7-7700K CPU and an NVIDIA GEFORCE GTX 1070 GPU. Which would be recommended for hardware transcoding in Plex when just considering transcoding speed on a single transcode? Additionally, would a GTX 1060 be slower for transcoding?

i7-7700k is plenty and would be overkill. The GTX cards are better for use as a gaming GPU, via a regular computer or via the unraid remote gaming guide.

I just want to know which of the two is faster at transcoding. I already have those two and just have to decide if I want to use QuickSync or NVENC. I want to be able to transcode 4K HDR.

QuickSync.

1 Like

Hello All,

Long time viewer first time poster….and new Linux user at that. I have purchased my HP 290 and have installed Ubuntu Desktop 20.04 on the machine. I am struggling with mounting my windows 10 shared drive. Currently I am just trying to get the drive to mount to see if it works and then will edit the /mnt /fstab file so it will mount automatically. The idea is to try and mount the whole drive so I have access to all of the folders on there for Plex. To test I have tried the following command

sudo mount -t cifs //192.168.1.178/j /mnt/Plex ( It then asks for a password which I put in)

I get this error:
mount error(13): Permission denied

When I check the Kern.log I have the following error:

Dec 21 15:41:54 Plex-Server kernel: [ 2113.303927] CIFS VFS: cifs_mount failed w/return code = -13

Also i have went head and tried to edit the /etc/fstab file with the following:

//192.168.1.178/j /mnt/Plex ntfs,username=“Media Server”,password=XXXXXXX,iocharset=utf8,sec=ntlm defaults,noatime,nofail 0 0

I then do sudo mount -a and get this:

mount: /etc/fstab: parse error at line 13 – ignored

I know i must be missing something very simple in all of this, any help would be greatly appreciated.

I just set up mine, after getting a bunch of errors and watching various youtube videos / forum posts, the following worked for me in the fstab:

//ServerIP/sharename /where/to/mount cifs username=username,password=yourpassword,iocharset=utf8 0 0

If you have spaces in your share directories, use:

/040

I also made everything lowercase as case seemed to matter.

If that doesn’t work, you can try this guide (I didnt need to do this):

[Guide] Auto-Mounting Filesystems in Linux

Need quick advice, please… My QNAP TS251 just isn’t keeping up. I want to keep the QNAP for storage but dedicate something to Plex.

My transcoding requirements are usually simply burning subtitles with an occasional transcoded stream (most of my devices support direct play), HEVC support would be a huge plus but not a requirement. I also need fast RAR decompression and repair with par files. For this, should I go with the latest generation CPU? Is i7 an overkill for this? Whatcha recommend?

Anybody know what I am doing wrong here? I set the mounts in my fstab and my movie library shows up no problem but my tv show library is not showing up at all. Screenshot below of my fstab. Any ideas?

image

Because the space in “tv shows” is being interpreted as a parameter separater.

replace the space with \040 as in tv\040shows and it should work.

1 Like

Can’t you just use an escape character?

192.168.1.2:/mnt/user/tv /mnt/tv\ shows nfs defaults,noatime 0 0

2 Likes

This worked beautifully! Thank you!

Bob’s method above worked for me! Thanks JDM!