GA-7PESH2 stuck on boot logo when hard drives are connected


I have a dual Xeon setup based on the GA-7PESH2. I’m running Proxmox on a RAID 1 of small SSD. My VMs are stored on a WD 1Tb Bluedrive SSD. I recently added 2 WD 8tb drives shucked from My Books external drives in RAID 5 configuration for storage (I already had 1 installed).

When I installed the two new WD reds, I started the RAID from scratch. I used this fdisk to format the drives, chose fd for as partition type then created the RAID using mdam. Then I was able to create a PV, a VG and a LV, formatted it using mkfs.ext4. I copied a bunch of data and everything worked fine.

Today I installed updates in Proxmox and tried to reboot. Now I’m stuck on the Gigabyte logo and Proxmox won’t boot until I disconnect the 8Tb drives. Here is the way the drives are plugged :

  • WD Bluedrive SSD for VMs : Physical sata directly on the motherboard.

  • RAID 1 SSD for Proxmox : 2 of the 4 sata ports from the mini SAS breakout cable to the physical SAS electrical Sata port.

  • 2 * 8Tb drives : 2 other of the 4 sata ports from the mini SAS breakout cable to the physical SAS electrical Sata port.

  • 1 * 8Tb drive : On the second physical sata port directly on the motherboard.

(I know there is no logic in there…)

The weird thing is that when I unplug the sata ports of the 2 new 8Tb WD red (1 on a sata port on the MB and 1 on the mini SAS breakout cable), Proxmox is booting just fine. Except that it can’t mount the LV on the RAID obviously…

A little bit of help would be much appreciated because I think that formatting the drives and rebuilding the raid would be pointless…

[edit] added more accurate information about the way the drives are plugged.

Is your boot order set correctly? Screenshots of the BIOS?

Here are a few screenshots that might be relevant. The weird thing is that I can’t even get into the bios when the 2 new drives are plugged in. (so they are not on the screenshots…)

Thanks for the help :wink:

Would you mind uploading those images to the forum natively? It helps mobile users a lot!

Of course :wink:

Annotation%202019-11-13%20210802 Annotation%202019-11-13%20210831


Here is what I get when I change AHCI mode to RAID mode in the bios.

But with the new drives plugged in, I get stuck on this screen. Without the new drives, the system is booting just fine…