Flashing SAS2208 to IT mode when sas2flsh does not detect it

Here is an image from previous IR firmware installed, I was using it as RAID10…

Yeah, sorry. I don’t think of RAID 0,1,10 as RAID firmware; the 2308s won’t do anything beyond this. That takes a 2208 with its dual-cores. My fault for using incorrect terminology.

You can get the version 18 firmware for your Z840’s onboard 2308 here:


It’s under “Firmware,” and here is the link to the firmware file itself:


Hope this gets you back to P18. Once you get this going, you can try and flash generic Broadcom software if you wish. You can get that from Broadcom’s site, under legacy host bus adapters. Just make sure you choose the correct one for the hardware you have, and the functionality you are wanting to achieve. According to this page, it looks like your onboard 2308 is configured similarly to a LSI SAS9217-8i.

Hope this helps.

Having a bit of trouble with FreeDos where all the text wont fit on the screen and I cant figure out how to scroll up or make Freedos pause when it fills up the screen and then give me the hit enter to continue. Any help would be appreciated.

Don’t recall having this issue. Are you executing multiple commands from a single call? If so, separate them out. Else, the only other suggestion is to use EFI instead of FreeDOS.

It was just a single call, but I found a solution. I ran this command MODE CON lines=43 and this shrunk the text and allowed everything to show up on the screen.

Thanks for the help.

You’re welcome, but I did nothing. :yum:

Final update, finally had some time to go though the steps and OPs guide worked wonderfully!

1 Like

Hello, I am having a problem after performing the steps as described. I was not thrown any errors during the process, but my SAS onboard LED is red indicating a fault. When I boot into UEFI and do sas2flash list I get the response as shown in the picture. Is there any solution to this problem?

At this point it looks like you still have to do the last flash:

sas2flash -o -f 9207-8.bin

and then write the sasadd:

sas2flash -o -sasadd 500xxxxxxxxxxxxx

Thanks for this @spikebyte, I used this post and a video by Art of Server to flash an onboad M5110e on an IMB M4.
I couldn’t find any howto for this so I have written one up here IBM M5110e internal raid controller to IT mode HBA – Well Bugger Me


Hi. I flashed successfully an intel rms25cb080 that has a sas2208 to 9207-8i the only issues is the beeper and it does not work with sas expander RES2SV240. truenas kernel panics on boot if it is connected to sas expander. if I flash bios rom image it hangs when detecting drives. I thought it could be the sas address but I tried different ones and same result… I also tried older firmwares and still does not work… any idea why this happens?

I have an x9dr7-tf+ that I filled steps to flash it from a 2208 to 2308 l. Everything was successful while flashing, however, after rebooting it it hangs after you see the MPT Avago screen. Just sits at Inializing, anyone have any options?

I got a card with the same issue and try the above methods to solve the problem.
However, after i run megarec -m0flash 0 2208_16.rom
it return the following error:

Currently flashing component = APP
Error in programming image into Flash.
Error code = 64

Is there any advice on how to resolve the above error code?
Thanks a lot!!!

What does it mean when I run the megarec -adplist and it just sits there? I messed up my new lsi9217 and had to reboot after flash as i didnt have the new fw on usb…

Well after a while it comes back with Memory alloc error No PCI chips found. Now what?