F80 Flash Accelerator Firmware

I got 2 of the F80 Flash Accelerators in the group buy, and I’m looking to update the firmware. Apparently, though, you need an Oracle account to download firmware. This account has to be tied to an “official” support agreement.

Does anyone happen to have these latest firmware files? Thanks!

-Mal

Oracle’s and similar download gates are extremely annoying, I highly recommend using bugmenot for such things in the future - here’s some throwaway Oracle logins for ya.

Even with the account it still needs to be tied to an organization. Speaking of these f80s, is there any way to do RAID 0 on the card itself?

@Tritech that’s what I’m trying to do (RAID), so I’m not sure yet :slight_smile:

Keep me updated if you find out anything. Are you sure the firmware update is what we need?

Is this what we’re looking for? (the dropbox link)

Ahh so it seems that the SUN firmware doesn’t allow hardware raid, even though the LSI controller technically can. You need to flash warpdrive firmware. Unsure if this works though.

i did skim that thread before but i didn’t think it had what i was looking for.

earlier i grabbed the warpdrive firmware from Seagate and tried to flash with no luck. i need to do some further digging, or find someone that has already done it.

I just realized everything on my card is labeled sun but the bios still comes up as seagate warpdrive. But the firmware revisions match the sun ones posted in that dropbox link.

I found the procedure. Need to spin up a linux install. The guys site is down, but thanks to archive.org

https://web.archive.org/web/20190501003135/https://www.kasilag.me/warpdrive/

3 Likes

oh wow awesome! i was bummed when i saw the site was down, but figured i’d just try later. thanks so much for digging that up. hopefully i can take a look at this tonight!

ok i thought i did step 2 properly… but step 3 doesn’t like the firmware i extracted. i’ve never used a hex editor so i’m not sure i’m fully understanding what to extract. let me know if you have any luck?

I’m hung up on the hex edit editor as well.

" Copy the entire section starting from 000000EA 5AA5FA5A to 5AA5EA5A 4BFFF008 ."

Is that saying to replace 5AA5EA5A 4BFFF008 with 000000EA 5AA5FA5A or just copy everything between them. If the latter wtf do you do with it?

you’re supposed to copy everything in between them, and save it off as a new .bin file. that file gets used later in the firmware section. but i’m not sure i’m using the hex editor properly.

ok I’ve got it dumped and my SHA1 matches, did yours?

i wasn’t sure what to do with that SHA1 so i didn’t get that far. would you be able to post the bin file?

I got the thing flashed, but ddcli -listall doesn’t list the device. LSIutil still sees the card so I guess I can flash it back. Just kinda stuck.

I’m waaay out of my element, but going to give this a try tomorrow. Can you guys recommend a Linux distro? I’m a Windows guy that is learning my way around Unraid.

Pop_os, mint, and ubuntu are all pretty new user friendly. Just a warning, if you do mess this up there is a chance to brick the card. Supposedly there are ways to recover it, but that’s a whole 'nother can of worms.

oooookay! got mine to work! i may have bricked the first one… but i’m going to try and recover it when i have a physical linux box to slap it in. also, many MANY thanks to @Tritech for helping me out with this!!! i wouldn’t have been able to do this without them.

I did this on a Dell R620 running vSphere 6.7. I enabled passthrough of the F80, and attached it to a Ubuntu 18.04 VM. (Run everything as root!)

I ran through all the steps in the guide listed above: https://web.archive.org/web/20190501003135/https://www.kasilag.me/warpdrive/

For step 2.2 (creating new FW using a hex editor), I used the BIN file provided to me by @Tritech (THANK YOU!) because I apparently am incapable of using a hex editor properly :upside_down_face:

I followed the rest of the steps verbatim. During step 3 when it says to reboot the OS… if you’re doing this virtually like I did… REBOOT THE WHOLE HOST, NOT JUST THE VM. I’m pretty sure this is what hosed my original attempt.

After that… everything should be great!

Glad to see you got the second one working! I didn’t think about rebooting the whole host, which makes sense now that I think about it. Keep us updated if you manage to get the second one up and running again.

1 Like