Badblocks found on new 14TB IronWolf Pro


I have a brand new external seagate 14TB HDD delivered from b&hphoto to New Zealand. It was quite a good deal at only $225 USD landed.

I ran a long test using seagate tools and it passed. I shucked it and removed the Seagate IronWolf NAS Pro HDD inside and put it inside my plex server.

I ran a destructive badblocks test (takes 148hrs) and it found 385 badblocks (ie 0.00001% of blocks)

$ sudo badblocks -b 4096 -wsv /dev/sdc
Pass completed, 385 bad blocks found. (6/0/379 errors)

That’s 6 read / 0 write / 379 corruption errors.

$ sudo smartctl -a /dec/sdc

I’m not sure if having some badblocks on a 14TB HDD is an issue, as I’ve read that it’s fairly normal for a brand new HDD to have some badblocks during manufacturing and it’s only an issue if additional bad sectors crop up.

I’m not sure what to do, whether I should enquire about a return or not??

I’m just doing a smartctl long test now.

Maybe ask on Reddit r/datahoarder

I’m curious what the answer is myself. I thought hard drives handle/replace their own bad blocks seamlessly in the background so if a drive in use has reportable badblocks errors that’s a bad sign - but maybe yours hadn’t discovered them yet.

Return the drive. 14TB WD Easystores are $200 at Best Buy right now!

I’m planning to. I’m in New Zealand so can’t shop at best buy