Another NAS Killer 5.0 build not posting -- ASUS B85M-G and i7-4770t

Hey there!

I stole and tweaked the title from another recent “build not posting” issue, I’m facing a similar problem but with a different motherboard and CPU. :slight_smile:

I received the parts for my first server a couple days ago, here’s what I’m using:

  • Motherboard: ASUS B85M-G
  • CPU: Intel Core i7-4770t
  • CPU Cooler: ARCTIC Alpine 12 CO
  • RAM: 32GB 4X8GB DDR3-1600 PC3-12800U 240 Pin CL11 1.5V DIMM
  • PSU: Cooler Master Watt 650 Watt Semifanless Modular Power Supply, 80 PLUS Bronze
  • USB: SanDisk 32GB Cruzer Fit USB 2.0 (with Unraid installed on it)

I haven’t hooked up an SSD or hard drives yet, my understanding is that those aren’t needed for testing booting into the BIOS.

Here’s a summary of the behavior I’m seeing:

  • Motherboard light turns on when PSU is powered on.
  • No beeps when starting up (I don’t think this motherboard has a speaker though).
  • CPU fan turns on as expected.
  • Keyboard lights up for a split second when the PSU is turned on, but doesn’t seem to power it at all when trying to boot into BIOS.
  • Monitor doesn’t recognize any signal from the board.

Here’s what I’ve done so far:

  • Inspected the motherboard (I did this right when it arrived). Nothing obviously wrong with it, it seems to be in pretty decent shape.
  • Inspected the CPU socket, didn’t notice any obviously bent pins.
  • Removed battery for 5 minutes in an attempt to reset CMOS.
  • Shorted CLRTC pins with a screwdriver in another attempt to reset CMOS.
  • Tried a single stick of RAM.
  • Looked into the supported CPUs for my motherboard, it appears my motherboard has supported my CPU from day one (although it is a bit confusing since it says it has been supported since BIOS 0306 which doesn’t seem to exist on their site).
    • I also found that the version of the BIOS installed at the factory is printed on the barcode on the motherboard; mine says 0904 which is definitely newer than the BIOS version mentioned above.
  • Tried both HDMI and DVI. Haven’t tried VGA yet, not sure if I have any of those laying around. I can certainly try that if it may make a difference.

Is there anything else that I should try before declaring the board dead and trying to get a refund? Let me know if I need to provide any further information.

By the way, I’ve been converted on this whole “build outside of the case” thing… with my previous gaming PC builds I always built inside the case, after doing it this way I see the error of my ways!