4 Beeps -- Unknown Cause

My friend and I are trying to get our NAS up and running with the specs listed below. Every time I boot it up, regardless of what I try, I get 4 beeps and nothing on the VGA port.

So far I have tried:

  • Pulling the CMOS chip, waiting 5 minutes, and putting it back
  • Booting from a USB iso image
  • Burning the iso image to the 250GB SSD
  • Pulling out all the RAM sticks one by one

Current Specs:

  • Intel Xeon E3-1270 V2
  • Supermicro X9SCL Motherboard
  • 2x Kingston 16GB (2X8GB) PC3-10600E DDR3 1333 ECC Workstaion MEMORY
  • 2x Samsung 16GB DDR3 RAM 2x 8 GB PC3-10600E 1333Mhz 240PIN DIMM ECC Desktop Memory
  • Western Digital 250GB Blue 3D NAND SSD
  • EVGA 750W PSU

Our current theory is that we bought the wrong RAM. Could that be right?

Thank you so much for your help–I feel like I’m losing my mind a little bit.

I also had this RAM sitting around and just tried both of those with no luck.

TEAMGROUP Elite DDR3 16GB Kit (2 x 8GB) 1600MHz (PC3-12800) CL11 Unbuffered Non-ECC 1.5V UDIMM 240 Pin PC Computer Desktop Memory Module Ram Upgrade - TED316G1600C11DC01-16GB Kit (2 x 8GB)