12Gb SAS HDD Not Detected on GA-7PESH2

I have eight older 6Gb SAS disks connected via a couple SFF-8087 to SFF-8482 cables to my GA-7PESH2 and it has worked well the past few years. I have some newer 12Gb SAS disks that I was planning to swap in, but after swapping in one of the 12Gb SAS disks I noticed it wasn’t detected. I’ve performed a few basic troubleshooting steps (power cycled, reseated cables, tried a different 12Gb disk, etc.) and now I’m researching what may be causing the issue. Any ideas why the 12Gb SAS disk may not be seen?


I’m assuming you mean 12TB drives, lol.

Did you 3.3v mod them, by chance?

That was it! I cut the orange wire and the newer disk is being seen. Thank you for pointing me in the right direction. I’m surprised my initial searching didn’t immediately point to this issue as it seems common.

Now I need to find some SFF-8087 to SFF-8482 cables that don’t pass through 3.3v from my PSU’s SATA power connectors.


1 Like

All cables will pass that through, that’s what they are designed to do. You can just 3.3v mod.

These are the ones I recommend.