Windows won't boot with various SATA configurations

Hi folks,

I’ve just finished my build and am running into an issue where Windows fails to boot if I have drives plugged into certain SATA ports. I am running a Supermicro X9DRH-7F (Quick Reference - flashed to LSI 2308). After shucking my drives (1x WD MyBook 4TB, 4x WD easystore 8TB, 1x WD easystore 12TB) and plugging everything in (including a 500GB SSD for OS), Windows would fail to boot and just hang on the startup loading screen.

After playing around with things a bit, I realized that it will boot if I just have my SSD plugged into one of the SATA 3 ports. Additionally, I tested several of the drives in the other SATA 3 port and everything worked as expected in that case as well. However, if I plugged a drive into the port labeled S-SATA1, it hangs on boot again.

I’m hoping someone can provide some insight as to what could be causing this issue. I did a bit of research and everything I read said all of the ports should work for my use-case, maybe I missed something though? Or maybe I should just use the onboard SAS instead?

Thank you for your time!

Looks like SSATA ports are a different controller and may have RAID settings in the BIOS and/or may require additional drivers to work in Windows which would prevent Windows from successfully booting in their absence.

Ah I forgot to mention this as well… I tried just plugging my drives into the ISATA ports and it also hung on boot.

A bit more information, BIOS shows all drives under SATA/SCU configurations, so it’s clearly a driver I need. I’ve been directed to the download the drivers from the the following location: https://www.supermicro.com/products/motherboard/Xeon/C600/X9DRH-7F.cfm

However the drivers it downloads explicitly say windows 7/8, nothing about Windows 10. Also, how do I even install those drivers? It’s a bunch of .cat .inf and .sys files, I’m not sure what I would even do with them.

EDIT:
As was pointed out, I needed to install the SCU SATA driver from Supermicros website. Once that was installed everything worked as expected.

1 Like