[Official] Nexcom NDiS B533 - fanless desktop for pfSense, Roon endpoint, Parsec client, Car/RV PC, and more!

Auto accepting $60. :slight_smile:


If I wanted to add wifi to my B533 what would be the best way? USB? Mini-PCIe?

1 Like

Just impulse-bought mine last night on eBay, auto-accepted $60 offer. I don’t really have a specific purpose for it since I just upgraded my router to a HP T730, but might throw Linux on it and connect it to my office TV so I have a web browser. Can also function as a backup in case my T730 ever fails.

  1. I saw Italia’s comments about the “533-CX” model not being listed in the manual, and I couldn’t find any information on Nexcom’s website about it either, any ideas if this model was just a special build for a certain company or purpose, since it appears to have the same specs?

Thanks for pointing out this offer, looking forward to getting it soon!

Mini PCIe or USB 3.0 would work.
On the cheap, you can use something like this:

It could be as simple as an “as configured” notation, such as which SSD, RAM, and CPU is included. If it’s not on Nexcom’s site, it’s probably not that important.

The i5-4590T cpu boots up into bios just fine for the record. (35w)

i5-4590T with full 4 core load for ~1h, room temp, with zero airflow. Ended up at 54*C

1 Like

Thoughts on putting a Core i7-4765T in one of theses? 35W.

My initial thought is not worth it.

I looked at all of the various upgrades, if you can get a cpu thats 4 cores for ~$20 I think its a good deal compared to the G series it came with.

I added an Intel 802.11ac mini PCIe card to one of mine. Works perfectly. Card was short, so couldn’t screw it down, but it was super cheap, new and came with antennas.

Depends on what you’re using it for…

If anyone is interested in running bare metal Home Assistant OS on the Nexcom, you’ll need to make some manual configuration changes to allow HAOS to boot from a non-UEFI system. After installing HAOS to the SSD, I was able to get it to boot by following the instructions here Install HA on old laptop without UEFI - #20 by dbrand666 - Configuration - Home Assistant Community.

I’m copy/pasting the instructions here for posterity.

It’s not really necessary to install a full Linux just to load the EFI GRUB that’s included with the x86 image. We can just create a small partition and install GRUB into it and point it at the existing grub.cfg file. Use your favorite Linux live CD/DVD/USB (I’m liking Parrot OS today).

Use gparted to create a small ext4 partition on the HassIO drive. I’m assuming it’s /dev/sda. It’ll probably tell you that the partition table doesn’t include the whole disk and offer to fix it. Let it. A 10MB partition should be fine. Tell gparted to leave 0 bytes after the partition so it ends up at the end of the disk. That way HassIO will be able to resize its partitions and use all the unallocated space.

Note: You may end up with a tiny bit of unallocated space after this partition even if tell gparted to make it 0. That’s due to alignment. Don’t worry about it.

Mount the new partition (should be sda9 but check):

mount /dev/sda9 /mnt

Install GRUB on the new partition. If you’re using Parrot OS you’ll need to install the GRUB package first:

sudo apt install grub2

Then install GRUB onto the HassIO drive. Replace /dev/sda with your device if different:

sudo grub-install --compress=xz --root-directory=/mnt /dev/sda --force

Now that GRUB is installed, all that’s left is to configure it to redirect to the HassIO installation. Create a config file /mnt/boot/grub/grub.cfg and put the following in it (the first line tells it to use the first partition on the first drive, the second tells it where HassIO’s GRUB config file is):

set root=(hd0,1)
configfile /efi/boot/grub.cfg

Remove the boot media and reboot. You should go straight to the HassIO boot menu.


I made some horizontal stackers, and a vertical support to stand it on end. Here are the links:




I can confirm that an i5-4590S works in this.


I really like those stackers, nice work!


Anyone find a compatible RAM list or draft their own?

Tried some DDR3 sticks from laptops i had laying around but memtest conks out with some of my sets and mixing couple working ones (memtest runs fine) crash memtest that came with the 4GB apacer mine shipped with.

Also wonder if anyone has tried 32GB ram with one of the intel CPUs that support that much?

Ever figure out that RAM issue? Had some mixed sticks around from laptops that work fine, but hitting similar issues. Can’t find an approved RAM list either to buy something new with confidence it works.

Second the RAM request. Would love to upgrade from the 4GB

probably a dumb question - I’m still looking at and toying with buying a box to replace my router. as I really want to run something that will do intrusion detection and some flavor or pihole or such - while keeping most of my GB connection. Would this box do that?

or get close. I also toy with PF sense vs Opnsense vs IPfire - but never bit the bullet to go all in.

Looks really good from a use and power perspective at 80 dollars or less.

Reviving an old convo: I purchased this RAM and it worked great. MemTest returned no errors, ran it for four hours. Hope this helps someone out.



Thanks ordered the RAM sticks above.

Wondering about wireless cards now, will report back what I find.