NAS Killer v4.0 - X9SCL doesn't boot

Hello everyone,

I’ve started to assemble my NAS Killer v4.0. Here is my setup:

  • X9SCL board
  • E3-1220 v2
  • 2x8 GB 1600MHz PC3-12800E 240pin DIMM ECC

I’ve assembled everything and when plugging the power supply, it powers up and down constantly. I’ve double-checked that the CPU is correctly installed, the pins don’t look bent to me, I tried with only one RAM stick and changed the battery on the motherboard but nothing works.

It’s my first build and I don’t really know what’s happening, could I get some help in diagnosing the issue?

Thank you!

Can you share some pictures with us?

Here are all the picture I thought of taking of the build so far. I can take more if you need.

I’ve also noticed something on the SuperMicro website warning “*** BIOS rev. 2.0 or above is needed to support new E3-1200 v2 CPUs, which supports PCI-E 3.0 & DDR3 1600.”.

Could it be something related to this issue?

bios could be an issue. I want to say when I got mine the bios had never been updated. It came with a celeron so it booted up and then I updated the bios and installed the Xeon…in my case it was a E3-1220 v2 If I’m not mistaken I’ve since upgraded to a 4c/8t.

If you don’t find any other solution…try to find a cheap celeron and see if that works for you.

Thank you for your answer! I found a Celeron (SR0S8) at $5 on eBay. I ordered it and will be able to test if the problem comes from the Bios version next weekend.

I’ll update the thread if it solved the problem.

I’ve received the Celeron and installed it on the board. The board does not reboot automatically anymore, it rather stays powered on but there is no beep from the MB and nothing on the display.

I’ve tried switching RAM sticks and double-checked the position of all the jumpers on the board (they all are in default position).

I followed closely the installation procedure described in this video and other tabletop installation video.

I don’t know what else I could do about it, is there anything else I could do to diagnose the issue?

To me, sounds like a dead board… I’d probably just RMA it.