How do I fix recently added being stuck due to wrong date?

How do I fix this Its telling me some recently added media will actually be added in the future, I read its something to do with the wrong Unix Epoch Time stamp or something. https://19216801.onl/ https://routerlogin.uno/

I am looking for help please replying saying I had this and had to change it isn’t helpful, I have tried removing the media and rescanning, cleaning bundles and emptying trash (Plex Dance) and this fails. I have even tried to delete the entire library and all I get is a error that there was a problem performing that action

Plex uses the date and time the media was created to calculate the timestamp for recently added, even if that date is in the future. Based on the dates that are showing, I’m guessing you have Sonarr and Radarr set to change the file’s date to the release date/air date in the Media Management advanced settings.

image

You’ll want to change that setting to None to fix media added in the future. As for fixing your existing media, you need to fix the date for those existing files first. If you’re using unraid or a Linux distro for your file storage, you can open the terminal and run the touch command (touch myfile.mkv) to change the timestamp on the files to update them with the current date and time. Or, if you prefer, you can also use touch to update the timestamp to a previous date and time (touch -t YYMMDDmmss myfile.mkv). If you use Windows, there’s nothing built-in but you can use a third-party tool like Attribute Changer to update the timestamps. Either way, once you’ve updated the timestamps on the files you want, redo the Plex dance and the files will show up with the updated dates.