Fixing Sun Oracle (HGST) 8TB drives reporting 7.86TB

Just had to use this on some 10TB HGST SAS3 drives received from Bitdeals.tech. Super handy.

Did this natively in Unraid.

To reiterate:
sdX < Change this to whatever the device is labeled

sg_readcap /dev/sdX
sg_format --format --size=4096 /dev/sdX
sg_readcap /dev/sdX

Afterwards the second readcap command displays the correct drive size.

Without being super specific to the timing, it takes me <8h to reformat a 10TB drive.

Edit : Yes you do in fact have to keep the session open while it does the long slow format. Either use tmux, screen, or don’t reboot your computer.

3 Likes

Other than losing space, is there any benefit in leaving the drives at the 7.86tb size, do the extra parity bits help with sector/block recovery on the drive itself? Or does that require having a controller/software designed to take advantage of that parity?

Working on trying to get some of the 8tb drives to replace some aging 3tb drives in my Unraid server. So if there is an advantage to leaving the parity bits there, then I’m find with keeping them at 7.86 because that’s still more than double what I am replacing.

Thanks,

BTC

No benefit to leaving them at 7.86TB of which I’m aware.

Definitely format them. It doesn’t take very long.

In the user guide for the hugo tool, under format there is an option for protection type (0,1,2,3) but it doesn’t say what the different types are. Is the default no protection?

Yep, default is 0 (disabled). Note that hugo’s fast format is also not meant to work with unlike sector sizes (e.g. 520 → 4096, or 512 w/protection enabled).

1 Like

Should this work for the Rhino $60 10TB drives also? ST10000NM0226

sg_readcap /dev/sdX
sg_format --format --size=4096 /dev/sdX
sg_readcap /dev/sdX

I ordered 2 last week and they are only showing up as 9.93TB. Looks like it is similar:

Did you change out sdX with the drive letter of choice? I just did this for 4 of the drives in my system and had no problems getting the full capability.

Also, don’t forget to reboot after format for unraid to recognize new size

I have not done it yet, this is a long thread with various different attempts so I just was looking for confirmation of the correct commands to be ran - of course changing to the needed drive letter.

Did you run sg_format --format --size=4096 /dev/sdX or sg_format --format --fmtpinfo=0 /dev/sdX

1 Like

Thanks for the help! I did exactly that and I was able to get both of my new 10TB ST10000NM0226 drives to have the full 10TB instead of 9.93TB.

3 Likes

Hi, hopefully someone here can help me… I’ve made a mistake. I have a Dell r510 with a perc H700 raid controller, I installed my 8tb sun HGST set it up as raid 0 and it was found in windows but was missing some capacity… I did a Hugo format in windows to 4k. Problem is now the drive isn’t being recognized anymore. Its showing up in the H700 bios but only as a 900gb drive… if i try to make a Raid 0 with the drive it fails. I’m not very good with Linux & obviously windows also LOL!.

Is it possible to format this drive again with Linux?
If so how do i get the drive recognized and ready to format back to 512b

Thanks in advance for any help.

Hello all. Looks like I am a year late as I see that the last message was posted in March of 2023.

I am having an issue formatting an HGST 8TB drive Model #HUH728080AL5201 (Netapp) The drive appears to be fine except for the fact that I am unable to format it from the ubuntu command line. I have tried both sg-utils and Hugo. I tried most if not all of the suggestions made here and elsewhere to no avail. Your time and assistance will be greatly appreciated. I hope that it is alright that I attached several screenshots to this post.

CVC_HUH728080AL5201 - sg_format -  Failed

CVC_HUH728080AL5201 - sg_readcap -  Information

Would probably help if you at least outlined what you’ve tried as opposed to ‘i’ve tried everything’

Thank you @stuffwhy I don’t mind listing the cli commands that I used in sg_util and Hugo if that will help. I have had another HGST Sun/Oracle SAS 8TB HUH7280805200 drive installed and had no issued formatting that.

sg_format --format --size 512 --fmtpinfo=0 /dev/sdx (tried excluding fmtpinfo as well)
sg_format --format --size 4096 --fmtpinfo=0 /dev/sdx (tried excluding fmtpinfo as well)

hugo format -s xxxxxxxx -b 4096 --fastformat
hugo format -s xxxxxxxx -b 512 --fastformat

Tried with several switches as well. eg.
hugo format -s xxxxxxxx -b 4096 -n max -p 0 --fastformat