Can't get X9DRD-7LN4F-JBOD to recognize p400

Repost from reddit due to auto message. Thanks!

Hey guys I have a supermicro X9DRD-7LN4F-JBOD motherboard and I cannot for the life of me get it to recognize my p400 video card in unraid. I’m thinking it’s a bios setting or a jumper but I have no idea about any of that. Anyone know how to fix this problem? I’m using the nvidia unraid build 8.0. Thanks.

Have you tested it in another computer to verify that the card is functional?

lspci -tv? Different PCIe slot?

Yes I put it in my gaming pc and it recognizes the card no problem.

Yes I tried all of the slots. It didn’t show up in any of them.

Can you share some pics of how you have it installed?

It’s not mounted in the case bc I’ve been messing w it but it’s just an 8x to 16x riser cable. It works w the cable in my pc and the fan spins in the server.

Also, do you think it’s something easy like updating the bios on my motherboard? I was going to do it but it says don’t do it unless you absolutely have to or you can mess up your system so I got a little nervous about it.

Package just arrived from China w my riser I ordered 6 months ago. Looks like im up and running. It’s very strange bc that other cable worked fine in my PC but whatever I am just glad that it’s fixed!! Thanks again to everyone for taking time out to help me out. I really appreciate all of you!!!